Bug 841028 - Provide Information about missing parameters when services fail
Provide Information about missing parameters when services fail
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configserver (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jan Provaznik
dgao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 18:38 EDT by james labocki
Modified: 2012-12-04 10:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An Application Blueprint with unmatched reference parameters caused Audrey to repetitively log without information on missing parameters. This fix adds validation for cyclic and non-existent references. Cloud Engine now checks for missing references and provides these details to the user.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:15:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working (77.02 KB, image/png)
2012-09-17 21:16 EDT, dgao
no flags Details

  None (edit)
Description james labocki 2012-07-17 18:38:01 EDT
Description of problem:
When an application blueprint which includes a service is launched and the provides/requires parameters do not match the aeolus-audrey-agent waits endlessly for the parameters and no messages are delivered to the user in the user interface informing them why the services did not execute.


How reproducible:
launch an application blueprint with several images and reference parameters that are not provided.

Actual results:
/usr/bin/audrey hangs and logs to /var/log/audrey.log a repetitive message which is not informative of what it is waiting for.

Expected results:
At a minimum, log what parameters are missing. Ideally, send this information to the user through the user interface.
Comment 1 Greg Blomquist 2012-07-26 15:16:33 EDT
We'd like to look at this for 1.1.

Implementation notes:  would add code to conductor to validate the deployable pre-launch by matching "return" values to dependency parameters.
Comment 3 Mike Orazi 2012-08-06 18:25:24 EDT
I think this shoudl have already had devel-ack, so moving it back.
Comment 4 Jan Provaznik 2012-08-21 04:58:27 EDT
Fixed for this is pushed in commit 2d73ff1f7e8818dc39cb63571c6d3c2da4ad7457
Comment 6 dgao 2012-09-17 21:16:32 EDT
Created attachment 613834 [details]
working

[root@ibm-ls21-04 yum.repos.d]# rpm -qa | grep "aeolus-conductor"
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
aeolus-conductor-0.13.7-1.el6cf.noarch

Verified
Comment 8 errata-xmlrpc 2012-12-04 10:15:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.