Bug 841043 - [PATCH] licensecheck "Public domain" output causes truncation
[PATCH] licensecheck "Public domain" output causes truncation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmdevtools (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 20:36 EDT by Garrett Holmstrom
Modified: 2012-09-17 19:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:49:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for licensecheck Public domain truncation (420 bytes, patch)
2012-07-17 20:36 EDT, Garrett Holmstrom
no flags Details | Diff
Test case (1.30 KB, text/plain)
2012-07-23 19:40 EDT, Garrett Holmstrom
no flags Details

  None (edit)
Description Garrett Holmstrom 2012-07-17 20:36:40 EDT
Created attachment 598768 [details]
Patch for licensecheck Public domain truncation

Description of problem:
When licensecheck runs across a file that it determines to be "Public domain" it drops every previously-found license because it forgets to append them to the string "Public domain".  The attached patch fixes the problem.


Version-Release number of selected component (if applicable):
rpmdevtools-8.2-1.fc16.noarch


How reproducible:
Always


Steps to Reproduce:
Run licensecheck on a file with multiple licenses, the last of which is public domain


Actual results:
Public domain


Expected results:
Public domain $other_licenses
Comment 1 Ville Skyttä 2012-07-21 06:32:08 EDT
Same issue with WTFPL it seems. Applied in rpmdevtools git and forwarded to upstream devscripts maintainers, thanks.

http://git.fedorahosted.org/git/?p=rpmdevtools.git;a=commitdiff;h=1754e0a3ee2f2dce656aa591ddcb9d5f043c4a07
Comment 2 Garrett Holmstrom 2012-07-23 19:40:21 EDT
Created attachment 599871 [details]
Test case
Comment 3 Fedora Update System 2012-09-02 17:24:56 EDT
rpmdevtools-8.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpmdevtools-8.3-1.fc18
Comment 4 Fedora Update System 2012-09-02 17:25:49 EDT
rpmdevtools-8.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rpmdevtools-8.3-1.fc17
Comment 5 Fedora Update System 2012-09-02 17:26:42 EDT
rpmdevtools-8.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpmdevtools-8.3-1.fc16
Comment 6 Fedora Update System 2012-09-03 13:22:25 EDT
Package rpmdevtools-8.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmdevtools-8.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13208/rpmdevtools-8.3-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-09-11 20:24:15 EDT
rpmdevtools-8.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-09-11 20:33:35 EDT
rpmdevtools-8.3-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-09-17 19:49:39 EDT
rpmdevtools-8.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.