Bug 841059 - Today eog won't update
Today eog won't update
Status: CLOSED DUPLICATE of bug 841088
Product: Fedora
Classification: Fedora
Component: eog (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 22:29 EDT by Mikhail
Modified: 2012-07-18 07:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 07:18:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-07-17 22:29:57 EDT
Description of problem:
Today eog won't update

Resolving Dependencies
--> Running transaction check
---> Package eog.i686 0:3.4.1-2.fc17 will be updated
---> Package eog.i686 0:3.4.3-1.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================================
 Package                                Arch                                    Version                                         Repository                                          Size
=========================================================================================================================================================================================
Updating:
 eog                                    i686                                    3.4.3-1.fc17                                    updates-testing                                    2.7 M

Transaction Summary
=========================================================================================================================================================================================
Upgrade  1 Package

Total download size: 2.7 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
updates-testing/prestodelta                                                                                                                                       | 148 kB     00:00     
Processing delta metadata
Download delta size: 420 k
eog-3.4.1-2.fc17_3.4.3-1.fc17.i686.drpm                                                                                                                           | 420 kB     00:00     
Finishing rebuild of rpms, from deltarpms
<locally rebuilding deltarpms>                                                                                                                                    | 2.7 MB     00:03     
Presto reduced the update size by 85% (from 2.7 M to 420 k).
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package eog-3.4.3-1.fc17.i686
/var/tmp/rpm-tmp.MCTKuD: line 2: syntax error near unexpected token `||'
/var/tmp/rpm-tmp.MCTKuD: line 2: `for schema in eog || : ; do '
error: %pre(eog-3.4.3-1.fc17.i686) scriptlet failed, exit status 2
eog-3.4.1-2.fc17.i686 was supposed to be removed but is not!
  Verifying  : eog-3.4.1-2.fc17.i686                                                                                                                                                 1/2 
  Verifying  : eog-3.4.3-1.fc17.i686                                                                                                                                                 2/2 

Failed:
  eog.i686 0:3.4.1-2.fc17                                                                     eog.i686 0:3.4.3-1.fc17                                                                    

Complete!
Comment 1 Kalev Lember 2012-07-18 07:17:13 EDT
Thanks for catching this, much appreciated. I've fixed the prein scriptlet issue in eog-3.4.3-2.fc17.
Comment 2 Kalev Lember 2012-07-18 07:18:01 EDT

*** This bug has been marked as a duplicate of bug 841088 ***

Note You need to log in before you can comment on or make changes to this bug.