Bug 841064 - Unable to highlight text segments in search results of search/replace function
Unable to highlight text segments in search results of search/replace function
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6.1
Unspecified Linux
high Severity medium
: ---
: 2.0
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 22:42 EDT by Hedda Peters
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121116-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-07-17 22:42:21 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build Identifier: 

When using the search/replace function, I am unable to highlight text segments within the displayed results. 

To highlight I would usually point the mouse to the beginning of the desired text segment, click & hold, while moving to the end of the desired text segment. But as soon as I let go of the mouse button at this point, the highlighting of the text disappears. Instead, this caused the checkbox for this entry to be selected.

I cannot highlight (or, therefore, copy & paste) excerpts from search results.

Reproducible: Always
Comment 1 Runa Bhattacharjee 2012-07-30 08:10:53 EDT
Assigning to Zanata Dev team for evaluation
Comment 2 Sean Flanigan 2012-07-30 22:01:13 EDT
Let's just use the checkbox for selection, so that copy and paste will work.
Comment 3 Sean Flanigan 2012-11-08 21:18:06 EST
Is this caused by "click to select", or by codemirror's X selection problems on Firefox?
Comment 4 David Mason 2012-11-08 22:33:46 EST
This is caused by "click to select" and should be a fairly easy fix, just removing a little event handling code.
Comment 5 David Mason 2012-11-12 21:55:30 EST
Fixed in 2.0 and merged to 2.1.

Selection will now only occur when clicking on (or very near) checkboxes on the left of the row.

See: https://github.com/zanata/zanata/commit/7a46cbe15e8287f24dbddf957975894f06d09886
Comment 6 Ding-Yi Chen 2012-11-15 23:22:25 EST
VERIFIED with
Zanata version 2.1-SNAPSHOT (20121112-1056) 
and Zanata version 2.0.3-SNAPSHOT (20121116-0019)

Browser:
Google Chrome: 22.0.1229.94
Chromium: 21.0.1180.89 

Firefox 16.0.2
Firefox ESR: 10.0.10

Note You need to log in before you can comment on or make changes to this bug.