Bug 841065 - Definition of Sophie Germain primes is wrong in manual moduli.5
Definition of Sophie Germain primes is wrong in manual moduli.5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
16
All Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 22:48 EDT by Akihiro Nomura
Modified: 2012-12-06 22:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 22:28:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenSSH Project 2047 None None None 2012-11-05 11:36:06 EST

  None (edit)
Description Akihiro Nomura 2012-07-17 22:48:44 EDT
Description of problem:
man moduli says:
 4     Sophie Germain; (p+1)*2 is also prime.
but, (p+1)*2 is obviously NOT a prime.
It should be p*2+1.
http://mathworld.wolfram.com/SophieGermainPrime.html

Version-Release number of selected component (if applicable):
openssh-server-5.8p2-25.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man moduli
2. search for "Sophie"
  
Actual results:
 4     Sophie Germain; (p+1)*2 is also prime.

Expected results:
 4     Sophie Germain; p*2+1 is also prime.

Additional info:
Comment 1 Petr Lautrbach 2012-11-06 04:28:55 EST
Thanks for the report. I've pushed the fix [1], but since it's minimal documentation change I'll push an update later with other fixes.

[1] http://pkgs.fedoraproject.org/cgit/openssh.git/commit/?h=f16&id=ee0729e302ee922ea743a1f88e6603b8a7426d80
Comment 2 Fedora Update System 2012-11-26 11:13:23 EST
openssh-5.9p1-28.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openssh-5.9p1-28.fc17
Comment 3 Fedora Update System 2012-11-28 06:47:37 EST
Package openssh-5.9p1-28.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openssh-5.9p1-28.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19252/openssh-5.9p1-28.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-12-03 05:21:27 EST
openssh-6.1p1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openssh-6.1p1-3.fc18
Comment 5 Fedora Update System 2012-12-06 02:22:25 EST
openssh-6.1p1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-12-06 22:28:52 EST
openssh-5.9p1-28.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.