Bug 841113 - CIFS: Unknown mount option "UID=500" - error(22): Invalid argument
CIFS: Unknown mount option "UID=500" - error(22): Invalid argument
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 04:11 EDT by dwyatt
Modified: 2014-06-18 03:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 07:55:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dwyatt 2012-07-18 04:11:23 EDT
Description of problem:
  mount.cifs fails when "UID=500" arg is included


Version-Release number of selected component (if applicable):
  works with kernel-3.3.8-1.fc16.x86_64 and previous, fails with
  kernel-3.4.2-1.fc16.x86_64 and kernel-3.4.4-4.fc16.x86_64


How reproducible:
  always


Steps to Reproduce:
1. invoke mount.cifs with UID=500 option, it fails
2. invoke mount.cifs without UID=500 option, it succeeds

  
Actual results:
  share not mounted


Expected results:
  share mounted


Additional info:
  /etc/fstab entry looks like this:
  //salient/backup01  /mnt/Salient/backup01  cifs  credentials=/root/.smbcredentials,_netdev,UID=500,users,rw	1 1
Comment 1 Jeff Layton 2012-07-18 07:55:05 EDT
"UID=" is not a valid mount option. "uid=" is. In the past, cifs.ko ignored invalid mount options, but that changed in 3.4 kernels.

I'll go ahead and close this as NOTABUG, but feel free to reopen if you want to discuss it further.
Comment 2 dwyatt 2012-07-18 11:32:54 EDT
Confirmed, uid=500 arg to mount.cifs works as it should.  Thanks.
Worth noting, though, is that UID=500, under kernel-3.3.8-1.fc16.x86_64, was not ignored.  In that case, shared files had user_500:root owner:group.  With UID=500 excluded from the mount.cifs options, files were root:root on Win shares.
Comment 3 Jeff Layton 2012-07-18 12:08:06 EDT
Yes, my mistake...

The older mount option parser was case insensitive (ugh), which we couldn't replicate when we moved to the standard kernel option parser. Moving to using the format we advertise in the mount.cifs manpage (lowercase) is still the best option going forward.

Note You need to log in before you can comment on or make changes to this bug.