Bug 841148 - [rhevm] new storage domain dialogue: do not attempt to attach domain when data-center != up
[rhevm] new storage domain dialogue: do not attempt to attach domain when dat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Asaf Shakarchi
vvyazmin@redhat.com
storage
: Reopened
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-07-18 05:27 EDT by Haim
Modified: 2016-02-10 11:42 EST (History)
15 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 05:14:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (397.86 KB, application/x-gzip)
2012-08-01 10:02 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-07-18 05:27:35 EDT
Description of problem:

there is no point of trying to attach storage domain to data-center where status is not equal to up. 
we should either filter our those data-centers, prompt a message, or just create the new storage domain and not perform the attach operation. 

repro steps:

- create new storage domain
- make sure to chose data-center that its status = non-responsive
- login to a new lun
- choose lun and create the data-center
- createStorageDomain and attachStorageDomain will be sent after-wards (attach will fail). 

I would also suggest to add a link for recovery procedure at this point.
Comment 1 mkublin 2012-07-25 12:47:44 EDT
I look on that bug because of code review.
Couple of questions:
1. We have not non-responsive status on data-center, only non operational.
2. We have non-responsive status for host.
3. What was status of hosts during create and attach opration.
4. Logs, at least for engine
Comment 2 Haim 2012-08-01 10:02:32 EDT
Created attachment 601747 [details]
engine logs

(In reply to comment #1)
> I look on that bug because of code review.
> Couple of questions:
> 1. We have not non-responsive status on data-center, only non operational.
> 2. We have non-responsive status for host.
> 3. What was status of hosts during create and attach opration.
UP
> 4. Logs, at least for engine
you have - in the GUI i have non-responsive.

this is what I get on web-admin:

Error: Failed to attach Storage due to an error on the Data Center master Storage Domain.
-Please activate the master Storage Domain first.


2012-08-01 20:20:00,758 INFO  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (QuartzScheduler_Worker-32) [bd5247] ActivateStorage Domain. Bef
ore Connect all hosts to pool. Time:8/1/12 8:20 PM
2012-08-01 20:20:00,792 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (pool-4-thread-47) [bd5247] START, ConnectStorageServe
rVDSCommand(vdsId = 78e0bf24-d979-11e1-9e8e-001a4a16970e, storagePoolId = b8423a1f-8889-469a-b2fa-39ab78ac3a57, storageType = ISCSI, connectionList = [{ id: ce
7b6af6-5325-4d1f-9341-4d1b2ca59445, connection: 10.35.160.7 };]), log id: 5678b0a
2012-08-01 20:20:00,836 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVGInfoVDSCommand] (ajp-/127.0.0.1:8009-1) [42bfe73] FINISH, GetVGInfoVDSCommand, re
turn: [org.ovirt.engine.core.common.businessentities.LUNs@dd8e89f1], log id: 46fbf47b
2012-08-01 20:20:00,888 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (pool-4-thread-47) [bd5247] FINISH, ConnectStorageServ
erVDSCommand, return: {ce7b6af6-5325-4d1f-9341-4d1b2ca59445=0}, log id: 5678b0a
2012-08-01 20:20:00,888 INFO  [org.ovirt.engine.core.bll.storage.ActivateStorageDomainCommand] (QuartzScheduler_Worker-32) [bd5247] ActivateStorage Domain. Aft
er Connect all hosts to pool. Time:8/1/12 8:20 PM
2012-08-01 20:20:00,889 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.ActivateStorageDomainVDSCommand] (QuartzScheduler_Worker-32) [bd5247] START, ActivateS
torageDomainVDSCommand(storagePoolId = b8423a1f-8889-469a-b2fa-39ab78ac3a57, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = 4f38a9
96-dbeb-4981-885b-742b46a4714f), log id: 38fe88c9
2012-08-01 20:20:01,040 WARN  [org.ovirt.engine.core.bll.storage.AttachStorageDomainToPoolCommand] (ajp-/127.0.0.1:8009-9) [6f9d135] CanDoAction of action Atta
chStorageDomainToPool failed. Reasons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__ATTACH,ACTION_TYPE_FAILED_MASTER_STORAGE_DOMAIN_NOT_ACTIVE
Comment 3 Ayal Baron 2012-08-08 08:42:44 EDT
when creating domains GUI should filter out DCs that are not operational.
other than that, the error is correct.
Comment 4 Asaf Shakarchi 2012-12-03 11:31:51 EST
This is a more general infra problem  rather than a specific issue, so this BZ is just an example of a more general problem,

This is a long invocation and involves creation of async tasks,
The problem is that async tasks 'loose' the context of the user,

In the infra level there should be a support for preserving user context.
Comment 5 Asaf Shakarchi 2012-12-03 11:39:29 EST
Please ignore comment #4 as it's related to another bug,
Patch submitted:

http://gerrit.ovirt.org/#/c/9678/
Comment 6 Leonid Natapov 2013-01-31 11:22:09 EST
sf5. Non-Operational DCs are filtered.
Comment 7 Itamar Heim 2013-06-11 05:14:46 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 05:40:33 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.