Bug 84115 - error: Installed (but unpackaged) file(s) found when tried to rebuild from the samba.spec file
error: Installed (but unpackaged) file(s) found when tried to rebuild from th...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-12 09:08 EST by Rishi Gangoly
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 16:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rishi Gangoly 2003-02-12 09:08:18 EST
Description of problem: 

I get this error when rebuilding the samba rpm from the source rpm.
------------------------------------------------
checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/samba-2.2.7-root

error: Installed (but unpackaged) file(s) found:
    /usr/bin/findsmb
    /usr/share/man1/findsmb.1.gz
    /usr/share/man1/smbsh.1.gz
------------------------------------------------



Version-Release number of selected component (if applicable): samba-2.2.7-
2.src.rpm


How reproducible: rpmbuild -ba samba.spec



Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
I posted this query on the the mailing list "" and was told to do the following.

echo "%_unpackaged_files_terminate_build  0" >> ~/.rpmmacros
echo "%_missing_doc_files_terminate_build  0" >> ~/.rpmmacros

After doing that the problem went away.

Someone else suggested this link:
http://www.rpm.org/hintskinks/unpackaged-files/

And it was the same thing.

I downloaded the samba source rpm from the samba.org website and did not run 
into this problem and I did not have to change those two macros to get it to 
work.
Comment 1 Jay Fenlason 2003-02-13 16:49:14 EST
This is fixed in the 2.2.7a packages in the current beta.

Note You need to log in before you can comment on or make changes to this bug.