Bug 841161 - RHS2.0 ISO does not have 'linux' as a label in 'isolinux.cfg'.
RHS2.0 ISO does not have 'linux' as a label in 'isolinux.cfg'.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
2.0
All Linux
medium Severity unspecified
: ---
: RHGS 2.1.0
Assigned To: Anthony Towns
Ben Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 06:08 EDT by Vimal Kumar
Modified: 2015-05-15 14:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Kumar 2012-07-18 06:08:09 EDT
Description of problem:
-------------------------

* Is installing a RHS2.0 node over the network via kickstart supported or atleast considered a proper method of installation ?

* This is because there is no label named 'linux' defined in 'isolinux/isolinux.cfg' in a RHS2.0 ISO. 

* The isloinux.cfg configuration is as following :

<snip>
default install
prompt 1
timeout 30
display boot.msg
F1 boot.msg

label install
  kernel vmlinuz
  append initrd=initrd.img ks=file:/ks.cfg quiet

label rescue
  kernel vmlinuz
  append initrd=initrd.img rescue

label local
  localboot 1

label memtest86
  kernel memtest
  append -
</snip> 

I dont see our documentation talking anything about kickstarting with an RHS2.0 ISO.

So a user who tries to do a kickstart (assuming it will work as a normal RHEL ISO) will normally use something like 'linux ks=<URL>/ks.cfg' to try out a kickstart installation which will ofcourse error out with the message "Could not find kernel image: linux'.

Was the isolinux.cfg edited to omit out the 'linux' label on purpose ? Or am I overlooking something ?


Version-Release number of selected component (if applicable):
--------------------------------------------------------------

* RHS2.0

How reproducible:
------------------

* Always


Steps to Reproduce:
---------------------

1. Boot the machine with an RHS2.0 ISO to do a normal or network install.
2. Enter 'linux <further arguments>'
3. The installer will error out with the message "Could not find kernel image: linux'.


  
Actual results:
---------------

* The installer errors out with the message :

"Could not find kernel image: linux'.


Expected results:
------------------

* The installer should continue with the install taking 'linux' as a proper argument.
Comment 1 Ben Turner 2013-08-07 14:23:55 EDT
Verified on RHS-2.1-20130806.n.2-RHS-x86_64-DVD.iso, isolinux.cfg now has:

label linux
  kernel vmlinuz
  append initrd=initrd.img ks=file:/ks.cfg quiet asknetwork
Comment 2 Scott Haines 2013-09-23 18:29:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.