Bug 841168 - Error on update process
Error on update process
Status: CLOSED DUPLICATE of bug 841088
Product: Fedora
Classification: Fedora
Component: eog (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 06:25 EDT by Pavel Alexeev
Modified: 2012-07-18 07:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 07:18:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2012-07-18 06:25:31 EDT
Description of problem:
# LANG=C yum upgrade
Running Transaction
  Updating   : gtk3-3.4.4-1.fc17.x86_64                                                                                                                                                                                                 1/34 
  Updating   : libjpeg-turbo-1.2.1-1.fc17.x86_64                                                                                                                                                                                        2/34 
  Updating   : gtk2-2.24.11-1.fc17.x86_64                                                                                                                                                                                               3/34 
  Updating   : file-libs-5.11-2.fc17.x86_64                                                                                                                                                                                             4/34 
  Updating   : file-5.11-2.fc17.x86_64                                                                                                                                                                                                  5/34 
  Updating   : 6:kdelibs-common-4.8.4-8.fc17.x86_64                                                                                                                                                                                     6/34 
  Updating   : libchamplain-0.12.3-1.fc17.x86_64                                                                                                                                                                                        7/34 
  Updating   : libchamplain-gtk-0.12.3-1.fc17.x86_64                                                                                                                                                                                    8/34 
  Updating   : 6:kdelibs-4.8.4-8.fc17.x86_64                                                                                                                                                                                            9/34 
  Updating   : python-magic-5.11-2.fc17.x86_64                                                                                                                                                                                         10/34 
  Updating   : gtk2-immodule-xim-2.24.11-1.fc17.x86_64                                                                                                                                                                                 11/34 
  Updating   : gtk2-devel-2.24.11-1.fc17.x86_64                                                                                                                                                                                        12/34 
Error in PREIN scriptlet in rpm package eog-3.4.3-1.fc17.x86_64
/var/tmp/rpm-tmp.27usGC: line 2: syntax error near unexpected token `||'
/var/tmp/rpm-tmp.27usGC: line 2: `for schema in eog || : ; do '
error: %pre(eog-3.4.3-1.fc17.x86_64) scriptlet failed, exit status 2
  Updating   : libjpeg-turbo-devel-1.2.1-1.fc17.x86_64                                                                                                                                                                                 14/34 
error: eog-3.4.3-1.fc17.x86_64: install failed
  Updating   : gtk3-devel-3.4.4-1.fc17.x86_64                                                                                                                                                                                          15/34 
  Updating   : gtk3-immodule-xim-3.4.4-1.fc17.x86_64                                                                                                                                                                                   16/34 
  Updating   : libjpeg-turbo-1.2.1-1.fc17.i686                                                                                                                                                                                         17/34 
  Cleanup    : libjpeg-turbo-devel-1.2.0-1.fc17.x86_64                                                                                                                                                                                 18/34 
  Cleanup    : python-magic-5.10-5.fc17.x86_64                                                                                                                                                                                         19/34 
  Cleanup    : libchamplain-gtk-0.12.2-1.fc17.x86_64                                                                                                                                                                                   20/34 
error: eog-3.4.1-2.fc17.x86_64: erase skipped
  Cleanup    : 6:kdelibs-4.8.4-5.fc17.x86_64
Comment 1 Pavel Alexeev 2012-07-18 06:30:43 EDT
Coming new version from updates-testing also with this bug:

 Package                                            Arch                                                  Version                                                       Repository                                                      Size
=============================================================================================================================================================================================================================================
Updating:
 eog                                                x86_64                                                3.4.3-1.fc17                                                  updates-testing                                                2.7 M

Transaction Summary
=============================================================================================================================================================================================================================================
Upgrade  1 Package

Total download size: 2.7 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Download delta size: 422 k
eog-3.4.1-2.fc17_3.4.3-1.fc17.x86_64.drpm                                                                                                                                                                             | 422 kB     00:01     
Finishing rebuild of rpms, from deltarpms
<locally rebuilding deltarpms>                                                                                                                                                                                        | 2.7 MB     00:06     
Presto reduced the update size by 85% (from 2.7 M to 422 k).
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package eog-3.4.3-1.fc17.x86_64
/var/tmp/rpm-tmp.rjyAG5: line 2: syntax error near unexpected token `||'
/var/tmp/rpm-tmp.rjyAG5: line 2: `for schema in eog || : ; do '
error: %pre(eog-3.4.3-1.fc17.x86_64) scriptlet failed, exit status 2
  Verifying  : eog-3.4.3-1.fc17.x86_64                                                                                                                                                                                                   1/2 
eog-3.4.1-2.fc17.x86_64 was supposed to be removed but is not!
  Verifying  : eog-3.4.1-2.fc17.x86_64                                                                                                                                                                                                   2/2 

Failed:
  eog.x86_64 0:3.4.1-2.fc17                                                                                             eog.x86_64 0:3.4.3-1.fc17                                                                                            

Complete!
Comment 2 Kalev Lember 2012-07-18 07:16:59 EDT
Thanks for catching this, much appreciated. I've fixed the prein scriptlet issue in eog-3.4.3-2.fc17.
Comment 3 Kalev Lember 2012-07-18 07:18:31 EDT

*** This bug has been marked as a duplicate of bug 841088 ***

Note You need to log in before you can comment on or make changes to this bug.