Bug 841178 - SELinux postfix_qmgr_t disabled access to postfix_spool_maildrop_t
Summary: SELinux postfix_qmgr_t disabled access to postfix_spool_maildrop_t
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.9
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-18 10:50 UTC by Filip Bartmann
Modified: 2013-01-08 03:32 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-2.4.6-330.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-08 03:32:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0060 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2013-01-08 08:27:19 UTC

Description Filip Bartmann 2012-07-18 10:50:30 UTC
Description of problem:
Latest SELinux update prevents postfix_qmgr_t to access postfix_spool_maildrop_t.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Update SELinux to version selinux-policy-strict-2.4.6-329.el5.noarch
2. Try to use postfix
3.
  
Actual results:
#  scontext="root:system_r:postfix_qmgr_t:s0-s0:c0.c1023" tcontext="system_u:object_r:postfix_spool_maildrop_t:s0"
#  class="file" perms="getattr"
#  comm="qmgr" exe="" path=""
#  message="type=AVC msg=audit(1342608283.225:400920): avc:  denied  { getattr }
#   for  pid=32317 comm="qmgr" path="/var/spool/postfix/deferred/0/05E493D8108"
#   dev=vda1 ino=4030728 scontext=root:system_r:postfix_qmgr_t:s0-s0:c0.c1023
#   tcontext=system_u:object_r:postfix_spool_maildrop_t:s0 tclass=file"
allow postfix_qmgr_t postfix_spool_maildrop_t:file { rename write getattr setattr read lock unlink };
#  scontext="root:system_r:postfix_qmgr_t:s0-s0:c0.c1023" tcontext="system_u:object_r:postfix_spool_maildrop_t:s0"
#  class="dir" perms="search"
#  comm="qmgr" exe="" path=""
#  message="type=AVC msg=audit(1342608283.225:400919): avc:  denied  { search }
#   for  pid=32317 comm="qmgr" name="deferred" dev=vda1 ino=4030751
#   scontext=root:system_r:postfix_qmgr_t:s0-s0:c0.c1023
#   tcontext=system_u:object_r:postfix_spool_maildrop_t:s0 tclass=dir"
allow postfix_qmgr_t postfix_spool_maildrop_t:dir { read remove_name search write add_name };


Expected results:
No SELinux audit denials.

Additional info:

Comment 1 Miroslav Grepl 2012-07-18 10:53:46 UTC
Filip,
thank you for testing.

Comment 2 RHEL Product and Program Management 2012-07-18 11:09:06 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 3 Miroslav Grepl 2012-07-30 07:01:42 UTC
Fixed in selinux-policy-2.4.6-330.el5

Comment 7 errata-xmlrpc 2013-01-08 03:32:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0060.html


Note You need to log in before you can comment on or make changes to this bug.