Bug 841190 - pppoe-server enabled by default
Summary: pppoe-server enabled by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rp-pppoe
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Than Ngo
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-18 11:28 UTC by Robert Vogelgesang
Modified: 2013-07-19 00:16 UTC (History)
1 user (show)

Fixed In Version: rp-pppoe-3.10-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-18 13:08:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0952 normal SHIPPED_LIVE rp-pppoe bug fix update 2013-06-18 17:08:03 UTC

Description Robert Vogelgesang 2012-07-18 11:28:40 UTC
Description of problem:
After installation of rp-pppoe, the pppoe-server is enabled by default

Version-Release number of selected component (if applicable):
rp-pppoe-3.10-8.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install rp-pppoe using yum or the GUI
2. chkconfig --list pppoe-server shows that pppoe-server is enabled
3.
  
Actual results:
pppoe-server gets started at each boot.

Expected results:
pppoe-server should not run by default, but only when enabled by the admin.

Additional info:
IMHO, the standard usage of rp-pppoe is running DSL connections as a client, connecting to some remote server, and not running a DSL network access server.

Current Fedora has this fixed, but this could be a side-effect of the conversion to systemd instead of SysV init.

Comment 2 RHEL Program Management 2012-09-07 05:26:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 3 Than Ngo 2013-02-19 12:08:55 UTC
it's easy fix, grant devel ack for 6,5fast

Comment 9 errata-xmlrpc 2013-06-18 13:08:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0952.html


Note You need to log in before you can comment on or make changes to this bug.