Bug 841206 - Region and Language keyboard layout preview highlights Ctrl_L even I hold e.g. B, N and M together
Region and Language keyboard layout preview highlights Ctrl_L even I hold e.g...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libgnomekbd (Show other bugs)
7.0
x86_64 Linux
low Severity low
: beta
: 7.0
Assigned To: Rui Matos
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 08:20 EDT by Martin Simon
Modified: 2016-09-19 22:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:31:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2012-07-18 08:20:05 EDT
Description of problem:
In System Settings - Region and Language, keyboard preview, when I hold more keys together, they are not highlighted correctly and the Control_L is highlighted intead.

Version-Release number of selected component (if applicable):
control-center-3.4.2-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Go to System Settings -> Region and Language -> Layouts tab, press + button
2. Choose any layout and click Preview
3. Hold together B, N and M
  
Actual results:
B, N and Control_L is highlighted

Expected results:
B, N and M is highlighted

Additional info:
Comment 1 Bastien Nocera 2012-10-15 12:08:10 EDT
With GNOME 3.6, I can only get 2 keys to get highlighted (if you press B N and M in sequence, M will only be highlighted when you release B or N, for example).

That seems to be fine behaviour.
Comment 2 Martin Simon 2012-10-17 05:14:37 EDT
Yes, that fine to highlight only two keys in a moment as you said. But when I press B, N and M in sequence, I got highlighted B, N and Control L. I just don't know - why "Control L"? It should be fine with a limit of two keys, but there are 3 and the last it's not what I actually pressed.

And a small note:
If I press in sequence Q, W and E, exactly these keys are highlighted - no "Control L"
Comment 4 Vladimir Benes 2013-04-10 06:25:05 EDT
this works well now in GNOME-3.8
-> VERIFIED
Comment 5 Ludek Smid 2014-06-13 06:31:26 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.