Bug 841207 - Error retrieving row when creating new env under selected org
Error retrieving row when creating new env under selected org
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 08:26 EDT by Sachin Ghai
Modified: 2013-08-16 14:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 14:50:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error on UI while creating env under default org (46.62 KB, image/png)
2012-07-18 08:26 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-07-18 08:26:49 EDT
Created attachment 598871 [details]
Error on UI while creating env under default org

Description of problem:
Created a env under default org ACME_Corporation, raised following error on UI:

--
Error

There was an error retrieving that row:Not Found
---

Env was created successfully.

production.log says:
======================
[FATAL: 2012-07-18 14:52:22 #30735] 
AbstractController::ActionNotFound (The action 'show' could not be found for OrganizationsController):
  
Version-Release number of selected component (if applicable):
katello-0.2.45-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Select 'Manage orgnization' ==> select default 'ACME_Corporation' ==> Add new environment
2.
3.
  
Actual results:
Env created successfully, but following error raised on UI:

--
Error

There was an error retrieving that row:Not Found
---

Expected results:
No error should be there on UI

Additional info:
Comment 1 Mike McCune 2012-08-01 11:12:24 EDT
can you re-test with the latest code?  Og indicates this no longer occurs
Comment 2 Sachin Ghai 2012-08-02 07:28:42 EDT
Yes, I verified this issue with katello 0.2.50-1 its already fixed. Moving this to verified.
Comment 4 Mike McCune 2013-08-16 14:18:35 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.