Bug 841209 - nouveau: probe of 0000:08:00.0 failed with error -16
nouveau: probe of 0000:08:00.0 failed with error -16
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: 7.0
Assigned To: Ben Skeggs
Desktop QE
:
Depends On:
Blocks: 982785
  Show dependency treegraph
 
Reported: 2012-07-18 08:27 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:09:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (78.04 KB, application/octet-stream)
2012-07-18 08:27 EDT, Martin
no flags Details
Xorg.0.log (41.99 KB, text/x-log)
2012-07-18 08:29 EDT, Martin
no flags Details
dmesg for Quadro 400 and Quadro 600 (629.02 KB, application/octet-stream)
2012-07-18 10:15 EDT, Martin
no flags Details
dmesg for Quadro 295 and Quadro 300 (786.09 KB, application/octet-stream)
2012-07-18 10:16 EDT, Martin
no flags Details

  None (edit)
Description Martin 2012-07-18 08:27:59 EDT
Created attachment 598872 [details]
dmesg

Description of problem:
Second GPU is not properly detected and configured for use. It fails with:

[drm] nouveau 0000:08:00.0: VM: trapped write at 0x0000130000 on ch 0 [0x00000070] BAR/PFIFO_WRITE/IN reason: PAGE_SYSTEM_ONLY
...
nouveau: probe of 0000:08:00.0 failed with error -16

Version-Release number of selected component (if applicable):
kernel-3.3.0-0.20.el7.x86_64
xorg-x11-server-Xorg-1.12.0-5.el7.x86_64
xorg-x11-drv-nouveau-0.0.16-36.20120306gitf5d1cd2.el7.x86_64

nVidia Quadro 400
nVidia Quadro 600

How reproducible:
always

Steps to Reproduce:
1. Have a PC with 2 GPUs (no SLI)
2. Connect first monitor to one GPU and second to another.
3. Boot
  
Actual results:
System boots only with first monitor enabled. xrandr or Control Center does not provides any information about second monitor/GPU.

Expected results:
Second monitor is enabled after boot or can be configured.

Additional info:
see dmesg and Xorg log
Comment 1 Martin 2012-07-18 08:29:43 EDT
Created attachment 598873 [details]
Xorg.0.log
Comment 2 Martin 2012-07-18 09:42:43 EDT
Dual GPU setup does not work with following GPU combinations:

Quadro 400 and Quadro 600
Quadro NVS 295 and Quadro 400
Quadro NVS 295 and NVS 300

Another setup was not tested, but this is enough for illustration that this bug is not affecting only one generation or combination of GPUs.
Comment 3 Martin 2012-07-18 10:15:25 EDT
Created attachment 598898 [details]
dmesg for Quadro 400 and Quadro 600
Comment 4 Martin 2012-07-18 10:16:53 EDT
Created attachment 598899 [details]
dmesg for Quadro 295 and Quadro 300

added 2 dmesg logs with drm.debug=14
Comment 7 Ben Skeggs 2013-10-22 20:19:56 EDT
Hey Martin,

The dual-gpu handling you're seeing is not a bug, and is in fact exactly the expected behaviour currently with multiple GPUs and no xorg.conf.  It's possible to configure things otherwise in a few different ways, but it doesn't "just work".  I believe xserver 1.14 changes this, with the introduction of the Prime stuff, but I haven't personally tried it so I'm not 100% sure.

The VM error message in your first comment, however, *is* a nouveau bug.  Once a kernel with an updated DRM component is available, it'd be useful if you could re-test and see if it's not fixed already.

Thanks,
Ben.
Comment 8 Michal Domonkos 2013-11-21 10:24:45 EST
The latest Xorg 1.15 RC and kernel 3.10.0-53 do already support the dual-gpu setup but it's not very reliable when it comes to changing the screen layout via gnome-control-center.  One time I was successful but the other I was not (bug 1033080).  It's a good step towards the goal anyway!

Regarding the dmesg error that Martin was seeing, it's gone, so I think we can switch this bug to VERIFIED.
Comment 10 Ludek Smid 2014-06-13 08:09:31 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.