Bug 841214 - Region and Language keyboard layout preview freezes for a moment when it should highlight down arrow
Region and Language keyboard layout preview freezes for a moment when it shou...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libgnomekbd (Show other bugs)
7.0
x86_64 Linux
low Severity low
: beta
: 7.0
Assigned To: Rui Matos
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 08:43 EDT by Martin Simon
Modified: 2016-09-19 22:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 00:47:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2012-07-18 08:43:25 EDT
Description of problem:
In System Settings - Region and Language, Layout tab, keyboard layout preview, when I press down arrow key, the previewer freezes for a moment instead of correct highlight of the down arrow key.

Version-Release number of selected component (if applicable):
control-center-3.4.2-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Go to System Settings -> Region and Language -> Layouts tab, press + button
2. Choose any layout and click Preview
3. Click down arrow key and then something else
  
Actual results:
down arrow does not highlight and it freezes for a moment

Expected results:
down arrow highlights correctly and everything else too, no freeze or delay

Additional info:
Comment 1 Bastien Nocera 2012-10-15 12:26:43 EDT
Seems to be moving the focus to the button, which eats the key press.

Note You need to log in before you can comment on or make changes to this bug.