Bug 841244 - inconsistency on system info: Katello-Candlepin: unresponsive "Systems" page
inconsistency on system info: Katello-Candlepin: unresponsive "Systems" page
Status: CLOSED DUPLICATE of bug 841289
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity urgent (vote)
: Unspecified
: --
Assigned To: Dmitri Dolguikh
Garik Khachikyan
: Triaged
Depends On:
Blocks: 841289
  Show dependency treegraph
 
Reported: 2012-07-18 09:49 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 841289 (view as bug list)
Environment:
Last Closed: 2012-09-12 15:21:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
loading ... (54.93 KB, image/png)
2012-07-18 09:49 EDT, Garik Khachikyan
no flags Details
katello logs (1006.44 KB, application/x-gzip)
2012-07-18 09:52 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-07-18 09:49:46 EDT
Created attachment 598892 [details]
loading ...

Description of problem:
Having error on RHSM registration with activation key brings UI of "Systems" page to onloading state forever. Further usage of Systems through UI becomes impossible. CLI also has no way to remove conflicting data info (seems manually through DB only~)

Version-Release number of selected component (if applicable):
pulp-common-1.1.11-1.el6.noarch
katello-certs-tools-1.1.6-1.git.572.1606589.el6.noarch
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
katello-glue-pulp-0.2.45-1.git.20.0d974f6.el6.noarch
katello-0.2.45-1.git.20.0d974f6.el6.noarch
katello-configure-0.2.30-1.git.16.0e273d4.el6.noarch
candlepin-tomcat6-0.5.32-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-0.2.43-1.git.0.07c77a6.el6.noarch
katello-cli-0.2.43-1.git.0.07c77a6.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
mod_wsgi-3.3-3.pulp.el6.x86_64
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-glue-foreman-0.2.45-1.git.20.0d974f6.el6.noarch
katello-selinux-0.2.6-1.git.9.1606589.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-agent-1.0.4-1.git.11.1606589.el6.noarch
python-qpid-0.14-7.el6_2.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
katello-glue-candlepin-0.2.45-1.git.20.0d974f6.el6.noarch
pulp-1.1.11-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
candlepin-0.5.32-1.el6.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
katello-common-0.2.45-1.git.20.0d974f6.el6.noarch
katello-repos-0.2.5-1.el6.noarch
pulp-selinux-server-1.1.11-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.prepare System Group having usage limit of 2 systems
2.create AK having no usage limit
3.assign system group to that AK.
4. register 2 systems using that activation key
5. try the third one: 
error on rhsm output:
"Validation failed: You cannot have more than 2 system(s) associated with system group 'cloud'"
Refer to the Katello UI and visit Systems-> All page.

Actual results:
Nothing but the loading progress icon is shown (attached is the pict.)

Expected results:
Katello & Candlepin both should handle the rollback of failure(s) correctly.

Additional info:
Comment 1 Garik Khachikyan 2012-07-18 09:52:21 EDT
Created attachment 598893 [details]
katello logs
Comment 2 Dmitri Dolguikh 2012-09-11 09:37:58 EDT
duplicate of/similar to https://bugzilla.redhat.com/show_bug.cgi?id=841289, has already been fixed.
Comment 5 Mike McCune 2012-09-12 15:21:21 EDT
closing as a dupe. we don't need this

*** This bug has been marked as a duplicate of bug 841289 ***
Comment 6 Mike McCune 2013-08-16 13:56:16 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.