Bug 841256 - Invalid repository name used generating client entitlements
Invalid repository name used generating client entitlements
Status: CLOSED DUPLICATE of bug 838658
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 09:59 EDT by mkovacik
Modified: 2012-07-18 14:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 14:34:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen log (14.77 KB, text/plain)
2012-07-18 10:01 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2012-07-18 09:59:04 EDT
Description of problem:
Invalid repository name shown and used generating client entitlement. Generated entitlement contains it as well (what kind of works as expected then)...

Version-Release number of selected component (if applicable):
RHEL-6.3-RHUI-2.1-20120705.0-Server-x86_64-DVD1.iso

How reproducible:
1of1

Steps to Reproduce:
1. create a CDS cluster
2. upload RHN certificate
3. add RHEL 6 debug repositories:
  Red Hat Enterprise Linux 6 Server (Debug RPMs) from RHUI (6Server-i386)
4. assign the repositories with the cluster
5. create client entitlement for the repositories
6. invalid repository name shown:
  Red Hat Enterprise Linux 5 Server - Optional Productivity Applications (Debug RPMs) from RHUI
7. invalid extension generated in the certificate:
  .I/content/dist/rhel/rhui/server/5/$releasever/$basearch/productivity/debug
  
Actual results:
Invalid repository names shown and generated in the client entitlement certificate

Expected results:
Correct repository names shown and generated in the client entitlement

Additional info:
- see as well the attached screen log
Comment 1 mkovacik 2012-07-18 10:01:44 EDT
Created attachment 598896 [details]
Screen log
Comment 2 wes hayutin 2012-07-18 14:34:24 EDT
This should be fixed in the new iso. /me looks for git hash

*** This bug has been marked as a duplicate of bug 838658 ***

Note You need to log in before you can comment on or make changes to this bug.