Bug 841258 - document how to enable debuginfo downloading in rhel6
document how to enable debuginfo downloading in rhel6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Deployment_Guide (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Svoboda
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 10:00 EDT by Jiri Moskovcak
Modified: 2015-10-05 22:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 08:10:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2012-07-18 10:00:58 EDT
Description of problem:
The debuginfo install and bugzilla plugin are disabled by default in rhel6 and since the process is not straightforward we should document it either in deployment guide or as kbase article
Comment 3 Jiri Moskovcak 2012-08-17 04:45:54 EDT
To enable automatic debuginfo downloading user needs to tweak the file /etc/libreport/events.d/ccpp_event.conf. It should contain following lines:

EVENT=analyze_LocalGDB analyzer=CCpp
        abrt-action-analyze-core --core=coredump -o build_ids &&
        # In RHEL we don't want to install anything by default
        # and also this would fail, as the debuginfo repositories.
        # are not available without root password rhbz#759443
        # /usr/libexec/abrt-action-install-debuginfo-to-abrt-cache --size_mb=4096 &&
        abrt-action-generate-backtrace &&
        abrt-action-analyze-backtrace

all what's neede is to uncomment (remove leading '#') the line:

# /usr/libexec/abrt-action-install-debuginfo-to-abrt-cache --size_mb=4096 &&

so the final line is like this:

/usr/libexec/abrt-action-install-debuginfo-to-abrt-cache --size_mb=4096 &&

NOTE: please note, that the automatic debuginfo install won't work for non-root when the debuginfo packages are served from RHN repositories - more info: rhbz#759443
Comment 4 Jiri Moskovcak 2012-08-17 04:54:01 EDT
To enable bugzilla plugin the following steps have to be done:

1. install libreport-plugin-bugzilla
$ yum install libreport-plugin-bugzilla

2. edit file /etc/libreport/events.d/bugzilla_event.conf and add line:
EVENT=report_Bugzilla reporter-bugzilla -b

- this will enable the bugzilla plugin for ALL types of problem, if user wants to enable it only for a specific type of a problem, the line added to bugzilla_event.conf should look like this:

C/C++ crashes:

EVENT=report_Bugzilla analyzer=CCpp reporter-bugzilla -b

Python crashes:

EVENT=report_Bugzilla analyzer=Python reporter-bugzilla -b

Kerneloops crashes:

EVENT=report_Bugzilla analyzer=Kerneloops reporter-bugzilla -b

Note You need to log in before you can comment on or make changes to this bug.