Bug 841260 - mtpfs sees only directories, not files, on Verizon Wireless Samsung Galaxy S III with lots of data
mtpfs sees only directories, not files, on Verizon Wireless Samsung Galaxy S ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mtpfs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 10:06 EDT by Jonathan Kamens
Modified: 2013-01-17 19:51 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 11:19:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-07-18 10:06:27 EDT
I have a Verizon Wireless Samsung Galaxy S III with thousands of files in a several-levels-deep directory structure within its Music folder.

When I mount the phone with mtpfs (after working through various issues described in bug 840541, most notably disabling gvfs-gphoto2-volume-monitor and making sure to run the mtpfs command immediately after the phone is plugged in), mtpfs is able to mount the phone successfully, but then I notice two incorrect behaviors:

1. "find <mountpoint>" prints only "<mountpoint>/Phone" and "<mountpoint>/Playlists"; it does not recurse.

2. When I cd into <mountpoint>/Music and run "find .", it lists all the directories in the hierarchy, but none of the files.

3. When I cd into one of the individual directories that should have MP3's in it and do "ls", nothing is listed.

In contrast, as noted in bug 840541, go-mtpfs (https://github.com/hanwen/go-mtpfs/#readme) works just fine.
Comment 1 Richard W.M. Jones 2012-07-18 13:34:37 EDT
I can't even get mtpfs to see an SIII at all.  Seeing folders
would be a luxury!

I'm of a mind to ditch mtpfs  There seem to be a few mtpfs
alternatives:

 * go-mtpfs
 * jmptfs (http://research.jacquette.com/jmtpfs-exchanging-files-between-android-devices-and-linux/)

We need to select a package which is active upstream.
Comment 2 Jonathan Kamens 2012-07-18 16:24:36 EDT
(In reply to comment #1)
> I can't even get mtpfs to see an SIII at all.  Seeing folders
> would be a luxury!

You need to make sure gvfs-gphoto2 is disabled and run mtpfs within a couple seconds after plugging in the phone. See http://blog.kamens.us/2012/07/18/using-the-samsung-galaxy-s-iii-with-linux/ .
 
> I'm of a mind to ditch mtpfs  There seem to be a few mtpfs
> alternatives:
> 
>  * go-mtpfs
>  * jmptfs
> (http://research.jacquette.com/jmtpfs-exchanging-files-between-android-
> devices-and-linux/)

I haven't tried jmptfs. Go-mtpfs seems to be actively maintained, and the only problems I've encountered with it have been either bugs in my phone or (according to the go-mtpfs author) deficiencies in the MTP protocol (can't write 0-length files, can't update timestamps of files).

The downside to go-mtpfs is that it requires the Go compiler, so you would either need to finish the work to build Go RPMs for Fedora, or just include the Go binary package as one of the source packages for the go-mtpfs RPM (ugh!).
Comment 3 Jonathan Kamens 2012-08-14 09:41:20 EDT
(In reply to comment #1)
> We need to select a package which is active upstream.

FYI, this recent libmtp patch might help mtpfs work better:

http://libmtp.git.sourceforge.net/git/gitweb.cgi?p=libmtp/libmtp;a=commit;h=9aca3434f6316b75eed6c8c7f3ea7c7471fbdb1a

I can't test now since I'm not at home (so can't plug my phone in :-) but I'll see if I can find the time to rebuild libmtp with this patch and see if it makes a difference.
Comment 4 Sergey V. Udaltsov 2012-11-03 10:50:10 EDT
It was working with FC17 till recently. I suspect, the kernel update from 3.6.2 to 3.6.3 broke it. The phone Samsung Galaxy SIII (Android 4.1.1) shows:

"Unable to find software on your PC that can recognize your device. Service pack 3, Windows Media Player, version 10 or higher, for Windows XP or Android File Transfer for Mac OS must be installed."
Comment 5 Scott Robbins 2012-12-30 18:24:13 EST
I've found that simple-mtpfs is working well for me on Fedora 18.  (Using it in console mode, don't know how it works with a GUI.)

In ArchLinux, I have used jmptfs which worked quite well.  I haven't had much luck with go-mtpfs, (I tried the binary).  

(This is with a Samsung Galaxy SIII)
Comment 6 Richard W.M. Jones 2013-01-16 11:19:03 EST
(In reply to comment #5)
> I've found that simple-mtpfs is working well for me on Fedora 18.  (Using it
> in console mode, don't know how it works with a GUI.)

Thanks -- 'simple-mtpfs' just works for me, and enabled me to
easily back up the photos on my phone.
Comment 7 Richard W.M. Jones 2013-01-16 11:19:57 EST
Closing this bug since mtpfs is orphaned and abandoned upstream.
Please use something else, such as simple-mtpfs which WFM.

Note You need to log in before you can comment on or make changes to this bug.