Bug 841262 - RHEL 7 spice-vdagent does not enter full-screen with monitor resolution
RHEL 7 spice-vdagent does not enter full-screen with monitor resolution
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-vdagent (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 10:10 EDT by Bill Sanford
Modified: 2014-02-23 19:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-23 19:46:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-07-18 10:10:41 EDT
Description of problem:
When trying to have a remote-viewer go to full-screen, RHEL 7 spice-vdagent does not enter full-screen with monitor resolution, but maximizes the current resolution that is configured.

Version-Release number of selected component (if applicable):
RHEL-7.0-20120711.2

How reproducible:
100%

Steps to Reproduce:
1. Run remote-viewer and enter full-screen.
2.
3.
  
Actual results:
The remote-viewer only maximizes the "Full-screen" to the monitor's currently configured resolution.

Expected results:
The remote-viewer should maximize the "Full-screen" to the monitor's maximum resolution.

Additional info:

Both vdagents are running on the guest and host.

service spice-vdagentd status
spice-vdagentd.service - LSB: Agent daemon for Spice guests
	  Loaded: loaded (/etc/rc.d/init.d/spice-vdagentd)
	  Active: active (exited) since Tue, 17 Jul 2012 08:52:12 -0400; 1 day and 1h ago
	 Process: 950 ExecStart=/etc/rc.d/init.d/spice-vdagentd start (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/spice-vdagentd.service
Comment 2 Hans de Goede 2013-08-08 05:36:42 EDT
Bill, just to make sure I understand this correctly. The issue is that you've a monitor on the client side running at say 1600x900, but it is capable of doing 1920x1080, and you expect remote-viewer to change the client monitor resolution to 1920x1080 when going fullscreen ?
Comment 3 Bill Sanford 2013-11-19 10:33:19 EST
Yes Hans.
Comment 5 Marc-Andre Lureau 2014-02-23 19:46:11 EST
Changing the client resolution is wrong in many ways (unsafe, deletes user preference/configuration, breaks desktop layout window/icons, no safety/restore mechanism).

spicec used to do that, spicy used to have experimental code to do that, but virt-viewer will not. If you want higher resolutions, you need to configure your client monitor first.

Note You need to log in before you can comment on or make changes to this bug.