Bug 84133 - Panic in aic7xxx driver code during initial install
Panic in aic7xxx driver code during initial install
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-12 12:13 EST by Glen A. Foster
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-21 18:10:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2003-02-12 12:13:31 EST
Description of problem: I was installing on a system with only 2 36GB disks 
attached to an Adaptec 7899P controller.  I did a text-mode install (NFS 
install invoked as "text expert"), set up a 150MB /boot partition (ext3) 
on /dev/sda; the rest of /dev/sda was /.  /dev/sdb contained a 2GB swap 
partition and the rest of the drive was an ext3 filesystem named "/extra".

Text mode install went about its business, and right before package 
installation, in black-text-on-red-background appears the message:

Kernel panic: aic7xxx: unrecoverable BRKADRINT.
In interrupt handler, not syncing


Version-Release number of selected component (if applicable):
Stock Advanced Server 2.1 for x86, installing from CD.

How reproducible: don't know, this is the first time I've seen it
Comment 1 Tom Coughlan 2003-02-12 15:58:21 EST
Were there any subsequent indications of any hardware problems? Did you
eventually get the system installed?

The default aic7xxx driver is v5.2.5.  This driver tends to work well for older
adapters, and not so well with newer adapters.  The alternate driver, called
aix7xxx_mod (v6.2.1, in the e.3 kernel on the install CD) may work better with
newer hardware. You might try an expert install, and select the aix7xxx_mod driver.
Comment 2 Glen A. Foster 2003-02-17 14:49:24 EST
I don't know if the following is helpful or not, but with the 2.4.9-e.10 errata 
kernel, the problem no longer appears.
Comment 3 Glen A. Foster 2003-02-25 18:41:13 EST
More information: with the 2.4.9-e.10 kernel (e.g., my target kernel for 
certification work TBD), both the aic7xxx and aic7xxx_mod drivers are OK.
Comment 4 Glen A. Foster 2003-03-21 18:10:14 EST
Since the aic7xxx_mod driver has been there all along, I consider it 
a "reasonable" workaround to the issue.  Resolving defect as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.