Bug 841359 - The F11 (Full-screen toggle) sometime works and sometimes doesn't.
The F11 (Full-screen toggle) sometime works and sometimes doesn't.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 14:42 EDT by Bill Sanford
Modified: 2013-10-07 16:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 16:35:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-07-18 14:42:51 EDT
Description of problem:
When I launch the remote-viewer, sometimes F11 will bring a Remote-viewer window to full-screen mode and sometimes it wont.

With remote-viewer in windowed mode, open up an application, like gedit. With gedit in focus, press the F11 key. Now, gedit will go to full-screen mode since F11 is the "Hot key" for Windows and RHEL 7 OSs to have the application in and out of "Full-screen" mode. If I then press F11 again, then the gedit window will then return to its original windowed size within the windowed SPICE VM.

If I then close gedit (And with no other applications running) and press the F11 key, this *should* bring the "windowed" SPICE VM to full-screen and the SPICE VM does not get out of windowed mode until you click on the SPICE window titlebar to reset the focus to the actual VM and not inside it.

The F11 key should also be a toggle and it can only be used if the SPICE window is in windowed mode and you must use the hidded drop down from the remote-viewer at the top of the SPICE VM.

Version-Release number of selected component (if applicable):
RHEL-7.0-20120711.2

How reproducible:
100%

Steps to Reproduce:
1. In description
2.
3.
  
Actual results:
F11 is not a hotkey and doesn't work until specific focus requirements are met.

Expected results:
F11 is a hotkey and works to bring the SPICE VM in and out of full-screen.

Additional info:
Comment 1 Yonit Halperin 2013-10-07 14:34:33 EDT
IIUC the description, this doesn't sound like a bug. If the mouse is inside the vm, F11 is directed to the vm and not to the remote-viewer window. Spice doesn't have info about windows opened inside the guest, and can't guess to which window the F11 was directed, to the remote viewer, or to a windows inside the guest.
Comment 2 Marc-Andre Lureau 2013-10-07 16:35:10 EDT
Yonit is right. The hotkeys are not global by default, so all input is redirected to VM regardless of what is running in the VM, unless the mouse pointer is outside the display area (menu or toolbar, or some other application widget)

if hotkeys are specified by controller or command line, they become global and are catched by the client.

closing for now.

Note You need to log in before you can comment on or make changes to this bug.