This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 841390 - OfficeJet 4500 scan function is not working over netowrk, only usb
OfficeJet 4500 scan function is not working over netowrk, only usb
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 16:39 EDT by cblaauw
Modified: 2012-08-20 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 12:47:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of su -c "lpinfo -l -v" (2.54 KB, text/plain)
2012-08-18 16:12 EDT, cblaauw
no flags Details
contents of /var/log/cups/access_log after trying to print test page (346 bytes, text/plain)
2012-08-18 16:19 EDT, cblaauw
no flags Details
contents of /var/log/cups/error_log after trying to print test page (291.81 KB, text/plain)
2012-08-18 16:20 EDT, cblaauw
no flags Details

  None (edit)
Description cblaauw 2012-07-18 16:39:06 EDT
Description of problem:
OfficeJet 4500 scan function is not working over netowrk, only usb

Version-Release number of selected component (if applicable):

[root@m7 ~]# yum list installed | grep hplip
hplip.x86_64                     3.12.6-1.fc17                  
hplip-common.x86_64              3.12.6-1.fc17                    
hplip-libs.x86_64                3.12.6-1.fc17 
How reproducible:

always

Steps to Reproduce:
1.connect printer over ethernet
2.no scanner is shown in simple-scan, printing works
3.connect printer directly with usb, scanner is shown in simple-scan
  
Actual results:
no scanner shown in simple-scan or xsane

Expected results:
scan function is usable over ethernet

Additional info:
did work in earlier versions of fedora
Comment 1 Tim Waugh 2012-07-19 04:38:05 EDT
What does 'yum list installed libsane-hpaio' say?
Comment 2 cblaauw 2012-07-20 13:58:40 EDT
Sorry for being so late...

libsane-hpaio.x86_64             3.12.6-1.fc17      @updates
Comment 3 Tim Waugh 2012-07-23 07:47:24 EDT
If you disable your firewall temporarily, does it then work?
Comment 4 cblaauw 2012-07-23 12:05:05 EDT
Tried that already, didn't work
Comment 5 Tim Waugh 2012-07-23 12:15:22 EDT
What output does this command give?

SANE_DEBUG_HPAIO=255 scanimage -L
Comment 6 cblaauw 2012-07-23 15:53:09 EDT
SANE_DEBUG_HPAIO=255 scanimage -L
[sanei_debug] Setting debug level of hpaio to 255.
[hpaio] sane_hpaio_init(): scan/sane/hpaio.c 297
[hpaio] sane_hpaio_get_devices(local=0): scan/sane/hpaio.c 316

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[hpaio] sane_hpaio_exit(): scan/sane/hpaio.c 310
Comment 7 Tim Waugh 2012-07-24 04:17:52 EDT
What does 'lpstat -s' say?
Comment 8 cblaauw 2012-07-24 17:14:23 EDT
 lpstat -s
system default destination: Officejet-4500-G510g-m
device for Officejet-4500-G510g-m: dnssd://Officejet%204500%20G510g-m%20%5B697EF2%5D._pdl-datastream._tcp.local/
Comment 9 cblaauw 2012-07-25 15:19:15 EDT
Because of removing and re-adding of my printer the former output of 'lpstat -s' was wrong.

correct now is:

lpstat -s
system default destination: Officejet-4500-G510g-m
device for Officejet-4500-G510g-m: socket://192.168.2.108:9100


But still no scanner, firewall is off right now.
Comment 10 Tim Waugh 2012-07-26 06:16:28 EDT
I think the "hp" backend needs to be used for the printer (or any printer -- even a queue you don't use) in order to libsane-hpaio to know where to find the scanner.
Comment 11 cblaauw 2012-07-26 08:53:29 EDT
Can I reconfigure anything to change the backend? I added the printer using the default stuff in system settings.
Comment 12 Tim Waugh 2012-07-26 11:51:03 EDT
Yes.

1. Make sure you have the "hplip" package installed.
2. Use s-c-printer or hp-setup to add a new printer. (If using s-c-printer, select Network Printer -> Find Network Printer and enter '192.168.2.108'; then select the HPLIP connection type.)
Comment 13 cblaauw 2012-07-27 07:54:14 EDT
Thanks!

Adding the printer using hp-setup worked, the scanner is now recognized. Maybe the routines form hp-setup could be called by the system settings, so that in future everything works smooth for users that don't know the internals.

Think you can close the bug
Comment 14 cblaauw 2012-07-27 08:09:48 EDT
One more thing...

If I add the printer using hp-setup, the scanner works but is does not print. Address of printer is shown as 'localhost'
If using system settings it's the other way round. Address of printer is an ip-address.
Comment 15 Tim Waugh 2012-07-30 07:24:33 EDT
What does 'lpstat -s' say now?
Comment 16 cblaauw 2012-08-13 13:19:21 EDT
Hi Tim, I'm back from vacation and here's the requested information.


when printing works:

lpstat -s
system default destination: Officejet-4500-G510g-m
device for Officejet-4500-G510g-m: socket://192.168.2.108:9100
device for Officejet_4500_G510g-m_fax: hpfax:/net/Officejet_4500_G510g-m?ip=192.168.2.108

when scanner works and not printer:
lpstat -s
system default destination: Officejet_4500_G510g-m
device for Officejet_4500_G510g-m: hp:/net/Officejet_4500_G510g-m?zc=HP697EF2
device for Officejet_4500_G510g-m_fax: hpfax:/net/Officejet_4500_G510g-m?ip=192.168.2.108
Comment 17 cblaauw 2012-08-13 13:23:29 EDT
another configuration that does not print:

lpstat -s
system default destination: Officejet_4500_G510g-m
device for Officejet_4500_G510g-m: hp:/net/Officejet_4500_G510g-m?ip=192.168.2.108
device for Officejet_4500_G510g-m_fax: hpfax:/net/Officejet_4500_G510g-m?ip=192.168.2.108


Printing queue is emptied and dialogs are shown in message tray, even low color filling is shown, but nothing is printed.
Comment 18 Tim Waugh 2012-08-14 07:23:03 EDT
Could you please follow the procedure here to get a troubleshoot.txt file, and attach that file to this bug report using the Add an Attachment link above?

https://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter
Comment 19 cblaauw 2012-08-18 16:12:16 EDT
Created attachment 605390 [details]
output of su -c "lpinfo -l -v"
Comment 20 cblaauw 2012-08-18 16:19:44 EDT
Created attachment 605391 [details]
contents of /var/log/cups/access_log after trying to print test page
Comment 21 cblaauw 2012-08-18 16:20:27 EDT
Created attachment 605392 [details]
contents of /var/log/cups/error_log after trying to print test page

test page print was requested using system settings
Comment 23 Tim Waugh 2012-08-20 07:12:19 EDT
D [18/Aug/2012:22:17:28 +0200] [Job 142] prnt/hpijs/hpijs.cpp 268: unable to set device=HP Color LaserJet 2600n, err=48
D [18/Aug/2012:22:17:28 +0200] [Job 142] prnt/hpijs/hpijs.cpp 289: unable to set device=HP Color LaserJet 2600n, err=48
D [18/Aug/2012:22:17:28 +0200] [Job 142] **** Unable to open the initial device, quitting.

I think this printer needs a proprietary HP plugin before HPLIP will be able to drive it.

Use "hp-plugin" to install this plugin.

Alternatively, you said printing was working before you got scanning working -- in that case, you were most likely using a different driver.  You can of course switch back to using that driver (but keep the backend the same, to enable scanning).

To change just the driver, click the Change... button next to "Make and Model" in system-config-printer.
Comment 24 cblaauw 2012-08-20 07:21:41 EDT
Hi Tim,

yes, when I'm adding the printer using gnome system settings, printing works and not scanning. When using hp-setup it's the other way round. I'll try changing the model - if that doesn't work I continue using the config that allows me to print, the scanner is only very seldom used by me. But in Fedora 16 both functions did work without problems. I'll also have a look for the hp-plugin you mentioned. Thanks.
Comment 25 cblaauw 2012-08-20 12:47:32 EDT
I installed the plugins. then the printer only printed gibberish on a lot of sheets when asked to print a test page. I changed the type from hpijs to hpcups using system-config-printer. Now everything seems to work fine.

Thanks a lot, I'm closing the bug

Note You need to log in before you can comment on or make changes to this bug.