Bug 841405 - Cloud9 integration: getting "Permission denied" errors on Cloud9 console when trying to add remote OpenShift git repo
Cloud9 integration: getting "Permission denied" errors on Cloud9 console whe...
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 17:58 EDT by Nam Duong
Modified: 2015-05-14 21:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 13:22:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-07-18 17:58:44 EDT
Description of problem:
This was reported as a comment on our Blog:  https://openshift.redhat.com/community/blogs/look-ma-no-hands-developing-for-the-cloud-in-the-cloud-with-cloud9-ide

Steps to reproduce:
Follow the blog to step 6

Expected:  we should be able to add the remote OpenShift git repo to our Cloud9 workspace
Actual:  We get a permission denied

NOTE that I also tried removing/re-adding the Cloud9 ssh key to my account (also validated that I'm on the correct OpenShift account). 


Cloud9 also has a bug open: https://github.com/ajaxorg/cloud9/issues/1763

I suggest combining efforts.
Comment 1 Nam Duong 2012-07-19 20:47:32 EDT
This is hitting people.  Take a look at some of the comments on that blog.
Comment 2 Ram Ranganathan 2012-07-20 17:39:38 EDT
Added workaround to the github issue: 

Got a workaround for this -- looks to be some parsing issue on the command interpreter -- since running a git command gives a permission denied error but putting it into a script worked. 
Here's what I did:
In the cloud9 ide created a file called addrepo.py and added these commands into the file:
 
        import os
        os.system("git remote add openshift ssh://e318b598bee247698df28a49315e0fee@pytest-mptest.rhcloud.com:~/git/pytest.git")
        os.system("git remote -v")

And then just ran `python addrepo.py`

And it worked just dandy (you could use an equivalent ruby/js(with node)/php script as well).
Comment 3 Mrunal Patel 2012-07-20 17:42:38 EDT
Lowering severity since we have a workaround. The fix will have to come from 
c9.
Comment 4 Mrunal Patel 2013-02-14 13:22:17 EST
Closing since issue has been closed upstream - https://github.com/ajaxorg/cloud9/issues/1763#issuecomment-10264312

Note You need to log in before you can comment on or make changes to this bug.