Bug 841491 - WSRP: White spaces are required between publicId and systemId
WSRP: White spaces are required between publicId and systemId
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Portal (Show other bugs)
5.2.2.ER02
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 03:23 EDT by Michal Vanco
Modified: 2013-04-30 19:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 08:04:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBWS-3511 Major Closed WSDL parsing exception: org.xml.sax.SAXParseException: White spaces are required between publicId and systemId. 2016-10-12 12:03 EDT

  None (edit)
Description Michal Vanco 2012-07-19 03:23:50 EDT
This is a placeholder for JBoss WS issue JBWS-3511

It's not possible to test with Netunity public producer (v1) due to this issue.

Steps to Reproduce:
1. Log in as root in EPP 5.2.1
2. Navigate to Group / WSRP
3. Create a consumer named: netunity
4. Click "Create Consumer" button
5. Producer WSDL URL: http://wsrp.netunitysoftware.com/WSRPTestService/WSRPTestService.asmx?Operation=WSDL
6. Click "Refresh & Save" button
  
Actual results:
Unable to register netunity producer
Comment 1 JBoss JIRA Server 2012-10-05 06:41:43 EDT
Alessio Soldano <asoldano@redhat.com> made a comment on jira JBWS-3511

Also see [1] , this looks to me a duplicate of the issue already raised there.
There's actually not a lot to do here to solve the problem, the issue is in the OASIS redirecting HTTP requests for their WSRP WSDL to HTTPS with an HTTP 302 response that includes an XML document that has a public ID but no system ID. Correct schema resolution is not possible in that case.

As suggested / discussed in [1] and [2], the "solution" here is leveraging catalogs to avoid the need for going to the internet to resolve the WSRP wsdl & schemas. Depending on the jbossws stack in use (native or cxf based), that is done using either as explained in [2] (native stack) or using jax-ws-catalog.xml catalogs (cxf stack). Attached is an example of jaxws catalog that can be used to read the schemas/wsdl from the file system (but you can also use "classpath:/" to read from jars in the classpath). I've been successfully testing that using the zip wsrp-entity-fix.zip attached to [1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=831445
[2] https://issues.jboss.org/browse/JBPAPP-9337
[3]
Comment 2 JBoss JIRA Server 2012-10-05 07:25:30 EDT
Alessio Soldano <asoldano@redhat.com> made a comment on jira JBWS-3511

Also see [1] , this looks to me a duplicate of the issue already raised there.
There's actually not a lot to do here to solve the problem, the issue is in the OASIS redirecting HTTP requests for their WSRP WSDL to HTTPS with an HTTP 302 response that includes an XML document that has a public ID but no system ID. Correct schema resolution is not possible in that case.

As suggested / discussed in [1] and [2], the "solution" here is leveraging catalogs to avoid the need for going to the internet to resolve the WSRP wsdl & schemas. Depending on the jbossws stack in use (native or cxf based), that is done using either as explained in [2] (native stack) or using jax-ws-catalog.xml catalogs (cxf stack). Attached is an example of jaxws catalog that can be used to read the schemas/wsdl from the file system (but you can also use "classpath:/" to read from jars in the classpath). I've been successfully testing that using the zip wsrp-entity-fix.zip attached to [1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=831445
[2] https://issues.jboss.org/browse/JBPAPP-9337
Comment 3 JBoss JIRA Server 2012-10-05 07:26:34 EDT
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3511 to Resolved
Comment 4 JBoss JIRA Server 2013-02-13 10:35:04 EST
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3511 to Closed

Note You need to log in before you can comment on or make changes to this bug.