Bug 8415 - cannot export 2 dirs on *same* partition + have to stop nfs to umount cdrom or zip when exported
cannot export 2 dirs on *same* partition + have to stop nfs to umount cdrom o...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-12 15:26 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 21:54:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-01-12 15:26:54 EST
RH61 2.2.14

(FYI: I know that knfsd only wants to export files and directories on the
same partition)

1) When exporting 2 directories that are on the *same* partition, I repeat
on the *same* partition, I get "Invalid argument" when invoking exportfs
-av. The clients get "permission denied"
Mounting 2 dirs that are on different partitions is no problem.

exporting / and /tmp on the same partition hda5:
/ is exported.
/tmp gives "invalid argument" when exportfs -av is invoked.

exporting / and /boot (on hda5 and hda1)
both directories are exported. ok.

2) When exporting a directory like /mnt/cdrom or /mnt/zip (with mounted
disks) everything is fine until you want to umount the cdrom or the zip.
Even after all clients have disconnected, the umount still says that the
dir is busy. Only when nfs is stopped I can umount a cdrom or a zip.
It is also not possible to export the directories /mnt/cdrom and /mnt/zip
when the cdrom or the zip is not mounted, see bug #1 above. I think that is
because an unmounted /mnt/cdrom is behaving like a directory on the same
partition and a mounted /mnt/cdrom is behaving like a directory on another
partition(?).

The only bug-fix for me at the moment is to recompile and install the
user-space nfs of RH52 (which works fine in the oldfashioned way on a RH61
system).

I'm sorry to say, but knfsd makes RH61 unworkable if you want to do more
than just exporting 1 single directory. With knfsd, I have to say to all
the users on the network to stop working for a few minutes when a zip has
to be mounted/umounted. That's a quite ridiculous situation, IMHO.

Richard Lucassen.
Comment 1 Mike Schwarz 2000-02-11 20:15:59 EST
In my tests it works like the other NFS servers that I use.  You can
export multiple directories on a single fs but one cannot be a sub-directory
of another.  I tries exporting /tmp and /var and it worked fine.  I got
the same problem exporting /tmp and then / but when exporting / and then
/tmp got lots of errors and rpc.mountd died.

I'm also having problem #2.  I have stopped nfs and still can't umount
/cdrom.  fuser -m /cdrom shows nothing.
Comment 2 Michael J. Rensing 2000-03-03 16:33:59 EST
It seems to me that point #1 is a logical behaviour. If you've exported the
parent directory, the sub directories are all accessable as well.

Point #2, however, seems like a real bug. I see the same behaviour. Put a CD in
the drive and mount it locally, export it, and mount it on another computer via
NFS, unmount it, and try to umount on the local machine. It doesn't work.
`umount -f /mnt/cdrom` produces two messages:
umount2: Device or resource busy
umount: /mnt/cdrom: device is busy

`fuser -v /mnt/cdrom` produces:
                   USER           PID ACCESS COMMAND
/mnt/cdrom         root        kernel mount  /mnt/cdrom
Comment 3 Need Real Name 2000-03-03 16:52:59 EST
You said:
It seems to me that point #1 is a logical behaviour. If you've exported the
parent directory, the sub directories are all accessable as well.

But:
In the old situation with the user space nfsd (RH52) it was possible to export /
and a subdir of / with different rights e.g.:

/              192.168.1.*(rw,no_root_squash)
/home/windows/ 192.168.1.*(ro)

In the new situation /home/windows always has to be on a different partition.

Richard
Comment 4 Cristian Gafton 2000-08-08 22:35:53 EDT
assigned to johnsonm
Comment 5 Stephen John Smoogen 2003-01-24 21:54:16 EST
Bug 8415 is being closed because most if not all of its items were fixed in
later kernel and nfs-util releases.

Note You need to log in before you can comment on or make changes to this bug.