Bug 841503 - sync with upstream 0.4.7 and drop the patches
sync with upstream 0.4.7 and drop the patches
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xournal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 04:28 EDT by Michael J Gruber
Modified: 2016-01-31 20:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 07:52:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J Gruber 2012-07-19 04:28:31 EDT
Fedora carries version 0.4.5 of xournal while 0.4.6 has been released and requested quite a while ago and 0.4.7 has been released recently. Please sync with upstream.

Currently, xournal as in Fedora also contains a feature enhancement patch which does not exactly fit the packaging guidelines. (It had not been included by upstream because of code quality concerns.)

This feature has been recoded and included upstream now. So, that feature enhancement patch can be dropped from the spec.

Also, 0.4.7 contains various fixes (0.4.6 did already) so that *all* patches can be dropped from the spec now. I'd be happy to jump in and comaintain if desired.
Comment 1 Jaromír Cápík 2012-08-13 05:48:25 EDT
Hello Michael.

I had a discussion with upstream developers several weeks ago and it was my intention to wait till the image insertion patch gets in the upstream sources. They promised to merge it and release in the 0.4.7 and I planned to do the update this week.
Regarding the feature enhancement, I believe I've already mentioned in the previous bug why I was willing to do an exception in this case. Moreover, there's no difference between introducing features with patches and introducing them in form of newer source tarballs. It's still a new feature introduction and thus kinda unwanted. I did the exception since the patch also fixes some bugs.

Regards,
Jaromir.
Comment 2 Michael J Gruber 2012-08-16 06:50:46 EDT
(In reply to comment #1)
> Hello Michael.
> 
> I had a discussion with upstream developers several weeks ago and it was my
> intention to wait till the image insertion patch gets in the upstream
> sources. They promised to merge it and release in the 0.4.7 and I planned to
> do the update this week.
> Regarding the feature enhancement, I believe I've already mentioned in the
> previous bug why I was willing to do an exception in this case. Moreover,
> there's no difference between introducing features with patches and
> introducing them in form of newer source tarballs. It's still a new feature
> introduction and thus kinda unwanted. I did the exception since the patch
> also fixes some bugs.

The difference is of course that the image insertion patch is not from upstream and was actually declined in that form by upstream (Denis). It was reworked by Denis quite a bit before taking it over now in 0.4.7 (which is not the Fedora package version).

It is a feature enhancement and does not fix any bugs. I would have requested the command line '-A' enhancement, others their favourite non-upstream enhancements; it's just a big no-no according to packaging guidelines.

Cherry picking bug fix patches is a completely different matter, of course.

You see, not following guidelines is often easier for the packager; but they are there for a reason.
Comment 3 Jaromír Cápík 2012-08-16 12:59:31 EDT
Hello Michael.

Do you believe, that everything from upstream is always the best solution and everything from contributors is always the worst solution? Denis only simplified some parts, but it's still the same feature and can potentially introduce new issues. I decided to use the last patch revision, since Denis confirmed he wanna merge it and I didn't expect any major changes.

> It is a feature enhancement and does not fix any bugs ...

This was my mistake, because I read the patch description and there was a note about replacing an incorrect usage of g_free with g_object_unref, what typically causes crashes. But unfortunately that's only a fix of the initial image patch version from Victor Saase. So, you're right at this point. I should check that more carefully.

> You see, not following guidelines is often easier for the packager; but they are there for a reason.

Easier? The easiest thing is to say:

"Sorry, this is a feature introduction and I'm not gonna do that ... Closing this bug..."

Wasting a time with updates and risking an instability is way more difficult and uncomfortable. But we're here for users, right? "Guidelines" doesn't mean "Strict rules" and if you say you really can't live without the '-A' command line enhancement in F17, I would take that seriously and consider that a thing I should focus on and forward to upstream. I rejected a similar feature introduction in case of procps and request for colors in the watch command, since it's more critical package. But in that case I at least provided users with unofficial testing packages introducing the feature. Ignoring the user's wishes using the "guidelines" excuse is very buck-passing.

Regards,
Jaromir.
Comment 4 Jaromír Cápík 2012-08-16 13:42:38 EDT
And I forgot to mention, that I'm not against giving you the commit rights. But you haven't applied for them yet.

BR, J.

Note You need to log in before you can comment on or make changes to this bug.