Bug 84152 - pstruct CFLAGS should use -gstabs by default
Summary: pstruct CFLAGS should use -gstabs by default
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-12 20:55 UTC by Miloslav Trmac
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version: 5.8.1-90.rc2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 02:52:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miloslav Trmac 2003-02-12 20:55:56 UTC
Description of problem:
pstruct, a tool to dump C struct layout, does so by examining stabs
debugging directives in gcc output. Since 3.2, gcc defaults to
using DWARF2, not stabs, so pstruct doesn't work at all unless
you explicitly set CFLAGS='-gstabs -S'

Version-Release number of selected component (if applicable):
Phoebe 8.0.93 + RHN updates

Steps to Reproduce:
1.pstruct /usr/include/sys/stat.h
2.pstruct CFLAGS='-gstabs -S' /usr/include/sys/stat.h
    
Actual results:
1.no output
2.dump of struct layout, as expected.

Comment 1 Miloslav Trmac 2003-07-30 02:52:37 UTC
This is fixed in severn.


Note You need to log in before you can comment on or make changes to this bug.