Bug 841571 - Broken kernel-headers on PPC (was FTBFS: Monitor.c:1080:4: error: signed and unsigned type in conditional expression [-Werror=sign-compare])
Broken kernel-headers on PPC (was FTBFS: Monitor.c:1080:4: error: signed and ...
Status: CLOSED DUPLICATE of bug 837641
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 08:45 EDT by Karsten Hopp
Modified: 2012-07-24 14:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 14:12:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed Monitor.i (276.12 KB, text/plain)
2012-07-19 08:45 EDT, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2012-07-19 08:45:38 EDT
Created attachment 599132 [details]
preprocessed Monitor.i

Description of problem:
gcc -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -DSendmail=\""/usr/sbin/sendmail -t"\" -DCONFFILE=\"/etc/mdadm.conf\" -DCONFFILE2=\"/etc/mdadm/mdadm.conf\" -DMAP_DIR=\"/run/mdadm\" -DMAP_FILE=\"map\" -DMDMON_DIR=\"/run/mdadm\" -DFAILED_SLOTS_DIR=\"/run/mdadm/failed-slots\" -DUSE_PTHREADS   -c -o Kill.o Kill.c
Monitor.c: In function 'WaitClean':
Monitor.c:1080:4: error: signed and unsigned type in conditional expression [-Werror=sign-compare]
Monitor.c:1080:4: error: signed and unsigned type in conditional expression [-Werror=sign-compare]
cc1: all warnings being treated as errors
make: *** [Monitor.o] Error 1

There was a recent change in the glibc headers that exposed incompatible macros between kernel-headers and glibc-headers (bugzilla 837641 and bugzilla 840902).
It looks like packages need to make sure to include <linux/types.h> before all other headers to make sure the correct macros get used.


Version-Release number of selected component (if applicable):
mdadm-3.2.5-3.fc18

How reproducible:
always

Steps to Reproduce:
1.ppc-koji build --scratch f18 mdadm-3.2.5-3.fc18.src.rpm)
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=89511

Expected results:


Additional info:
Comment 1 Jes Sorensen 2012-07-24 12:48:39 EDT
Reading through https://bugzilla.redhat.com/show_bug.cgi?id=837641 it is
obvious that this is *not* a problem in mdadm, but rather a problem with
kernel-headers on PPC.

In particular comments #10 and #30

Trying to fix this by adding a hack to mdadm is just broken and plain wrong!

Please fix the kernel-headers package for PPC!

Jes
Comment 2 Josh Boyer 2012-07-24 14:12:38 EDT

*** This bug has been marked as a duplicate of bug 837641 ***

Note You need to log in before you can comment on or make changes to this bug.