Bug 8416 - sndconfig crashes when you select NeoMagic 256AV
sndconfig crashes when you select NeoMagic 256AV
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-12 15:35 EST by HP
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-13 10:35:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description HP 2000-01-12 15:35:49 EST
I have run sndconfig with --noprobe and --noautoconfig and selected
NeoMagic 256AV from the Device list.  After selecting it, I am presented
with a dialog box "Warning: On Dell Inspirion 3500 this drivers freezes
the system". And it asks me to continue [Yes] [No].  If I select [Yes] it
gives me the same dialog again, so I select [Yes] and it again displays
the dialog.  So I decided to click [No] which exited out of the sndconfig.

I have finished installing Red Hat Linux 6.1 on my SONY VAIO PCG-F340:
PII 366MHz
RAM 64M
HD  6.40GB

DISPLAY NeoMagic 256AV
SOUND   NeoMagic 256AV *

ETHERNET 3Com Megahertz XJ10BT/XJ10BC (PCMCIA)
MODEM    Rockwell (Stupid WinModem) *

* not configured

Could you please help
Comment 1 Bill Nottingham 2000-01-13 10:35:59 EST
Fixed in the latest sndconfig in Raw Hide.
Alternatively, just add 'alias sound nm256' to
/etc/conf.modules.
Comment 2 HP 2000-01-13 11:08:59 EST
I tried your suggestion.  But when insmod tries to load nm256.o module it gives
like 8 to 10 symbol unresolved error.

Any suggestion on what I should do?
Comment 3 Bill Nottingham 2000-01-13 11:17:59 EST
Use modprobe instead of insmod.
Comment 4 HP 2000-01-13 14:49:59 EST
Thaks, it works somewhat.  I can hear the system bell now (when you try to
backspace at the begining of line).  But I still am not able to play any
wav/mp3/realaudio files.  I tried diffrent players (KDE and GNOME).

Could you please help?

Here is the info I get when I type in lsdev:
Device            DMA   IRQ  I/O Ports
------------------------------------------------
cascade             4     2
dma                          0080-008f
dma1                         0000-001f
dma2                         00c0-00df
fpu                      13  00f0-00ff
ide0                     14  01f0-01f7 03f6-03f6 fcf0-fcf7
ide1                     15  0170-0177 0376-0376 fcf8-fcff
keyboard                  1  0060-006f
Mouse                    12
pic1                         0020-003f
pic2                         00a0-00bf
rtc                       8  0070-007f
serial                       03e8-03ef 03f8-03ff
smc91c92_cs               3  0100-010f
timer                     0  0040-005f
vga+                         03c0-03df

lsmod:
Module                  Size  Used by
smc91c92_cs            13680   1
ds                      5740   2  [smc91c92_cs]
i82365                 22640   2
pcmcia_core            39912   0  [smc91c92_cs ds i82365]
nm256                  64456   0
sound                  57240   0  [nm256]
soundcore               2372   6  [sound]
soundlow                 300   0  [sound]

If you need any other info please let me know.

Note You need to log in before you can comment on or make changes to this bug.