Bug 841626 - wrong names for files on deepburner-created iso
wrong names for files on deepburner-created iso
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 11:46 EDT by lg
Modified: 2012-07-23 08:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 08:04:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iso image created with deepburner (302.00 KB, application/x-cd-image)
2012-07-19 11:46 EDT, lg
no flags Details

  None (edit)
Description lg 2012-07-19 11:46:25 EDT
Created attachment 599193 [details]
iso image created with deepburner

Description of problem:
The file names on iso files created with deepburner free 1.9 (http://www.deepburner.com/) are displayed as line of "_" symbols when -J option is given to isoinfo

Version-Release number of selected component (if applicable):
cdrkit-1.1.11-10.fc17
genisoimage-1.1.11-10.fc17

How reproducible:
always

Steps to Reproduce:
1. run
isoinfo -J -f -i deepburner2.iso
  
Actual results:
/_______

Expected results:
/116-17-6.mol;1
Comment 1 Honza Horak 2012-07-23 08:04:03 EDT
Joliet extension allows to use Unicode names, that are defined in UCS-2 format only. Debugging isoinfo with the given iso file, I see file names in Joilet extension in ASCII, instead of UCS-2. Such strings cannot be correctly decoded, so isoinfo shows only _ characters, which is right.

So I'd say this is most probably not a bug in isoinfo, but in deepburner. Please, report this issue to deepburner developers.

Note You need to log in before you can comment on or make changes to this bug.