This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 841633 - Device notification dialog hides application menu.
Device notification dialog hides application menu.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
Unspecified Unspecified
medium Severity low
: rc
: 7.0
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 12:28 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:29:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
notification (56.98 KB, image/png)
2012-07-19 12:28 EDT, Martin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 633620 None None None Never

  None (edit)
Description Martin 2012-07-19 12:28:26 EDT
Created attachment 599195 [details]
notification

Description of problem:
Device notification dialog hides menu, see screenshot.

Version-Release number of selected component (if applicable):
gnome-shell-3.4.1-5.el7.x86_64
gtk3-3.4.3-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Open Gnome application like Nautilus
2. Connect flashdisk and wait for device notification pop-up.
3. Open menu in Gnome application. Need to be long enough to overlay with notification pop-up.
  
Actual results:
see screenshot

Expected results:
Application menu should be on top of notification. Menu has higher priority in current context.
Comment 1 Florian Müllner 2012-10-16 16:16:23 EDT
Also see https://bugzilla.gnome.org/show_bug.cgi?id=633620.
Comment 3 Florian Müllner 2013-04-29 14:48:12 EDT
The aforementioned upstream bug has been fixed, and notification popups / context menus now behave as suggested in comment #0.

Can you please verify that the issue is fixed?
Comment 4 RHEL Product and Program Management 2014-03-22 03:06:19 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Ludek Smid 2014-06-13 09:29:34 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.