Bug 841655 - repo create fails on fresh install of pulp
repo create fails on fresh install of pulp
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
urgent Severity unspecified
: ---
: Sprint 38
Assigned To: Jeff Ortel
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 14:38 EDT by Preethi Thomas
Modified: 2013-09-09 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 09:09:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulp.log (5.80 KB, text/plain)
2012-07-19 14:38 EDT, Preethi Thomas
no flags Details
admin.log (309 bytes, text/plain)
2012-07-19 14:40 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2012-07-19 14:38:28 EDT
Created attachment 599220 [details]
pulp.log

Description of problem:

I have a fresh first time install of pulp on an f17 box. repo create seems to be failing to be failing

Version-Release number of selected component (if applicable):

[root@preethi ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.315-1.fc17.noarch
[root@preethi ~]# 

How reproducible:


Steps to Reproduce:
1. Install pulp and try to create a repo
2.
3.
  
Actual results:

[root@preethi ~]# pulp-admin -u admin -p admin repo create --repo pulp --feed http://repos.fedorapeople.org/repos/pulp/pulp/v2/testing/fedora-17/x86_64/
The server indicated one or more values were incorrect. The server provided the
following error message:

   Pulp exception occurred: PulpDataException

More information can be found in the client log file ~/.pulp/admin.log.


Expected results:


Additional info:
Comment 1 Preethi Thomas 2012-07-19 14:40:13 EDT
Created attachment 599221 [details]
admin.log
Comment 2 Jay Dobies 2012-07-19 16:14:30 EDT
Assigning to Jeff; this is an RPM spec issue.
Comment 3 Jeff Ortel 2012-07-19 16:24:24 EDT
Updated platform/pulp.spec so that /etc/pki/pulp/ is owned by apache, not root.
Comment 4 Jeff Ortel 2012-07-20 11:37:09 EDT
build: 0.316.
Comment 5 Preethi Thomas 2012-07-23 11:12:19 EDT
verified
repo create on fresh instal of pulp works. So does updates.
Comment 6 Preethi Thomas 2013-01-07 09:09:40 EST
Pulp 2.0 released.

Note You need to log in before you can comment on or make changes to this bug.