Bug 841666 - Missing /usr/share/X11/fonts/encodings/encodings.dir file?
Missing /usr/share/X11/fonts/encodings/encodings.dir file?
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-fonts (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 15:55 EDT by James Pearson
Modified: 2017-12-06 07:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:36:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Pearson 2012-07-19 15:55:39 EDT
Description of problem:

The file /usr/share/X11/fonts/encodings/encodings.dir and /usr/share/X11/fonts/encodings/large/encodings.dir are a ghost files owned by xorg-x11-fonts-misc - but nothing creates these files. /usr/share/X11/fonts/encodings/encodings.dir can be used by mkfontscale when creating fonts.scale files

Version-Release number of selected component (if applicable):

xorg-x11-fonts-misc-7.2-9.1

Additional info:

The RPM spec file for xorg-x11-fonts creates /usr/share/X11/fonts/encodings/encodings.dir and /usr/share/X11/fonts/encodings/large/encodings.dir in the %install section but the %files section list these as %ghost files

This means that the contents of the various fonts.dir/fonts.scale created by various %post scripts from font RPMS have less entries when compared with RHEL 5 - and applications that require these 'missing' X11 font names can't find the fonts

Are these encodings.dir files meant to be ghost files?

I'm not sure if this is a bug or feature with RHEL 6
Comment 2 RHEL Product and Program Management 2012-09-07 01:30:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Jan Kurik 2017-12-06 07:36:13 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.