Bug 841725 - The given username and password cannot login the wordpress page successful When created a wordpress app.
The given username and password cannot login the wordpress page successful Wh...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
: 841970 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 23:22 EDT by Mengjiao Gao
Modified: 2015-05-14 21:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mengjiao Gao 2012-07-19 23:22:46 EDT
Description of problem:
After created a WordPress application in the website,user can get a initial username(Admin) and password(OpenShiftAdmin). But when I use the given username and password to login the wordpress page, it said:"Error:The password you entered for the username admin is incorrect"

Version-Release number of selected component (if applicable):
devenv_1904

How reproducible:
always

Steps to Reproduce:
1.Create a Wordpress application.And write down the given username and password.
2.Open the url of your wordpress app,click "log in" in the page.
3.Ipput the given username and password.
  
Actual results:
Error message for login failed.

Expected results:
It should login successfully.

Additional info:
Comment 1 Mengjiao Gao 2012-07-19 23:34:37 EDT
This issue exists on the production as well.
Comment 2 Ram Ranganathan 2012-07-20 20:24:15 EDT
The production issue should have gone away as the merge commit has been reverted in the https://github.com/openshift/wordpress-example

And so should the devenv. 

Rolled back the commit and sent a new pull request. 

The main issue is in the templates using hardcoded passwords.
Comment 3 Xiaoli Tian 2012-07-22 23:53:11 EDT
*** Bug 841970 has been marked as a duplicate of this bug. ***
Comment 4 Mengjiao Gao 2012-07-23 01:16:37 EDT
Tested this issue on production and the INT environment, both of the given user and password can login the app url correctly.So I will changed it to verified.

Note You need to log in before you can comment on or make changes to this bug.