Bug 841735 - RFE: locale manager should auto-complete any languages we have info for
RFE: locale manager should auto-complete any languages we have info for
Status: CLOSED DEFERRED
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 01:17 EDT by Sean Flanigan
Modified: 2015-08-06 01:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-10 18:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-07-20 01:17:40 EDT
When adding languages via the admin menu, there are some locales for which we do have the language name (via ICU?), but they don't appear in the drop-down, and they don't work for auto-complete either.

See bug 836946 for background.

We may not want to add every language to the initial drop-down list if it gets too long, but language codes should at least auto-complete if they are known to ICU.
Comment 1 Parag Nemade 2012-12-26 04:34:37 EST
Is there any update for this issue?
Comment 3 Damian Jansen 2014-12-01 00:51:16 EST
I think this may be fixed now, or will at least be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1162383
Comment 4 Parag Nemade 2015-01-12 00:46:31 EST
I lost the interest in zanata bugs now.
Comment 5 Parag Nemade 2015-01-12 00:47:36 EST
ah sorry this is not filed by me. reverting previous change.
Comment 6 Michelle Kim 2015-02-24 23:04:36 EST
Sean, 

From Damian's comment, this bug might be already fixed. Can you please confirm?
Comment 7 Michelle Kim 2015-02-25 00:05:24 EST
Hi Alex,

Do you think you can provide any information on this bug? If it's already fixed with your other bug 1162383? Cheers
Comment 8 Alex Eng 2015-02-25 00:33:05 EST
Michelle, 

This bug should be fixed now with the new auto complete in our add language dialog.
Comment 9 Sean Flanigan 2015-02-25 21:48:33 EST
Autocomplete is still not working for languages like doi.  The same probably goes for some of the other languages mentioned in bug 836946.
Comment 10 Sean Flanigan 2015-02-25 21:50:17 EST
(In reply to Sean Flanigan from comment #9)
> Autocomplete is still not working for languages like doi.  The same probably
> goes for some of the other languages mentioned in bug 836946.

Yes, the same goes for mni, sat and sd.  hne is apparently not found in our version of icu4j.
Comment 11 Michelle Kim 2015-03-10 01:05:21 EDT
Hi Sean, 

Is this something that we can/should work on in next 6 month to a year? If not, what do you think about closing the bug as deferred and re-open it if there's more request for this feature? I wish to have bugs that are not going to be worked on due to resource limitation to be closed for now so that we can focus on the bugs/issues that are more urgent. Thanks for your input!
Comment 12 Sean Flanigan 2015-03-10 02:22:03 EDT
Hi Michelle, 

That sounds reasonable.
Comment 13 Michelle Kim 2015-03-10 18:54:13 EDT
Thanks Sean for your input. Closing this bug as DEFERRED.

Note You need to log in before you can comment on or make changes to this bug.