Bug 841838 - python client unable to create x-bindings using address string
python client unable to create x-bindings using address string
Status: CLOSED DUPLICATE of bug 726695
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
2.2
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: messaging-bugs
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 07:18 EDT by Leonid Zhaldybin
Modified: 2014-11-09 17:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 06:35:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Zhaldybin 2012-07-20 07:18:25 EDT
Description of problem:
Python client is unable to create node binding using 'x-bindings' parameter in the address string in case that both nodes are already created. Creation of the nodes themselves works flawlessly, but when the 'x-bindings' parameter is given, the client returns success without actually creating a binding.

Version-Release number of selected component (if applicable):
python-qpid-0.14-9.el6_3
python-qpid-0.14-7.el5

How reproducible:
100%

Steps to Reproduce:
1. Create new queue: qpid-config add queue q
2. Create new exchange: qpid-config add exchange topic e
3. Try to create a binding using address string: /usr/share/doc/python-qpid-0.14/examples/api/spout "q;{ create: always, node: { type: queue , x-bindings: [{ exchange: 'e', queue: 'q', key: 'key' }]}}"
4. Check if the binding was created: qpid-config -b queues
  
Actual results:
there is no binding between queue 'q' and exchange 'e'.

Expected results:
The binding created successfully.

Additional info:
The c++ clients do not have this problem.
Also, if the step 1 from the above reproduction scenario is omitted (or the step 2 is omitted and the address string in step 3 is changed into e;{ create: always, node: { type: topic , x-bindings: [{ exchange: 'e', queue: 'q', key: 'key' }]}}"), then the binding gets created.
Comment 1 Justin Ross 2013-02-27 06:35:02 EST

*** This bug has been marked as a duplicate of bug 726695 ***

Note You need to log in before you can comment on or make changes to this bug.