Bug 841853 - cumin cannot start because postgresql fails to start on EL5
cumin cannot start because postgresql fails to start on EL5
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: 2.2
: ---
Assigned To: Matthew Farrellee
Daniel Horák
: Regression
Depends On: 818585 842759
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 07:58 EDT by Stanislav Graf
Modified: 2012-09-21 07:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 14:26:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stanislav Graf 2012-07-20 07:58:31 EDT
Description of problem:
# echo yes | cumin-database install
WARNING

This script installs a cumin database into the system postgresql
instance.  It will take the following actions as necessary.

 * It will stop and start the postgresql service.

 * It will initialize the postgresql database cluster if it isn't
   already initialized.

 * It will alter postgresql configuration files.

If you already have a custom-configured postgresql install, you may
not want to proceed.

If there are clients that depend on the running postgresql service,
you probably don't want to proceed.

If, however, none of these changes affect your existing deployment, it
is safe to proceed.

Enter 'yes' to proceed or Ctrl-C to cancel:


Attempting to use initdb option...
 | $ /sbin/service postgresql initdb
 | Usage: /etc/init.d/postgresql {start|stop|status|restart|condrestart|condstop|reload|force-reload}

initdb option not supported, using start...
 | $ /sbin/service postgresql start
 | Initializing database: [  OK  ]
 | Starting postgresql service: [FAILED]

# cumin-admin add-user cumin cumin
Can't talk to the database
Error: Run 'cumin-database check' as root for more information

# cumin-admin add-assignment cumin admin
Can't talk to the database
Error: Run 'cumin-database check' as root for more information

# service cumin start
Starting cumin: ESC[60G[ESC[0;31mFAILEDESC[0;39m]
Cumin's database server is not running

# cumin-database check
Checking environment ........ OK
Checking initialization ..... OK
Checking configuration ...... Error: The database is not configured
Hint: Run 'cumin-database install'

Version-Release number of selected component (if applicable):
cumin-0.1.5419-4.el5.noarch
postgresql-8.1.23-5.el5_8.i386
postgresql-libs-8.1.23-5.el5_8.i386
postgresql-server-8.1.23-5.el5_8.i386

How reproducible:
100%

Steps to Reproduce:
1. Try to install cumin as usual
  
Actual results:
Suddenly (cumin 5419-4) new installation stopped working only on RHEL5.

Expected results:
Installation works on RHEL5 as always.

Additional info:
Comment 2 Trevor McKay 2012-07-20 10:00:54 EDT
This is due to a failure in starting postgres.

This seems to be due to Bug 818585.

With SELinux in permissive, postgres starts.

On an older 5.8 isntallation with a previous sudo, postgres starts with SELinux on ( sudo-1.7.2p1-13.el5)
Comment 3 Trevor McKay 2012-07-20 10:06:16 EDT
Forgot to mention...

(In reply to comment #2)
> This is due to a failure in starting postgres.
> 
> This seems to be due to Bug 818585.
> 
> With SELinux in permissive, postgres starts.
> 
> On an older 5.8 isntallation with a previous sudo, postgres starts with
> SELinux on ( sudo-1.7.2p1-13.el5)

I removed sudo and re-installed (sudo-1.7.2p1-14) and restarted postgres with SELinux enforcing, postgres start failed.
Comment 4 Stanislav Graf 2012-07-23 02:08:17 EDT
Workaround:
(1) install RHEL 5
(2) yum update (including broken sudo)
(3) touch /.autorelabel
(4) reboot
(5) install cumin and it's dependencies
Comment 6 Daniel Horák 2012-08-08 06:08:03 EDT
It's look like there is another problem - see bug 846631.
Comment 8 Martin Kudlej 2012-08-21 04:53:17 EDT
Tested with 
condor-7.6.5-0.20.el5
condor-aviary-7.6.5-0.20.el5
condor-classads-7.6.5-0.20.el5
condor-qmf-7.6.5-0.20.el5
condor-wallaby-base-db-1.22-5.el5
condor-wallaby-client-4.1.3-1.el5
condor-wallaby-tools-4.1.3-1.el5
cumin-0.1.5444-2.el5
postgresql-8.1.23-5.el5_8
postgresql-libs-8.1.23-5.el5_8
postgresql-server-8.1.23-5.el5_8
python-condorutils-1.5-4.el5
python-qpid-0.14-11.el5
python-qpid-qmf-0.14-14.el5
python-wallaby-0.12.5-10.el5
python-wallabyclient-4.1.3-1.el5
qpid-cpp-client-0.14-21.el5
qpid-cpp-client-ssl-0.14-21.el5
qpid-cpp-server-0.14-21.el5
qpid-cpp-server-ssl-0.14-21.el5
qpid-qmf-0.14-14.el5
qpid-tools-0.14-5.el5
ruby-qpid-qmf-0.14-14.el5
ruby-wallaby-0.12.5-10.el5
wallaby-0.12.5-10.el5
wallaby-utils-0.12.5-10.el5

sudo-1.7.2p1-14.el5_8.3

and it works.

Note You need to log in before you can comment on or make changes to this bug.