Bug 841866 - cgi scripts disappear on update
cgi scripts disappear on update
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: trac (Show other bugs)
el6
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Felix Schwarz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 08:46 EDT by Ferry Huberts
Modified: 2014-11-08 06:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-08 06:58:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ferry Huberts 2012-07-20 08:46:56 EDT
Description of problem:
when I update trac from 0.12.2-1 to 0.12.3-3.el6 via yum update trac, the 
trac cgi scripts in /var/www/cgi-bin disappear


Version-Release number of selected component (if applicable):
0.12.3-3.el6

How reproducible:
always

Steps to Reproduce:
1. update trac from 0.12.2-1 to 0.12.3-3.el6 via yum update trac
  
Actual results:
no trac cgi scripts in /var/www/cgi-bin

Expected results:
new trac cgi scripts in /var/www/cgi-bin

Additional info:

my shell log:


# cd /var/www/cgi-bin/
# l
total 16K
drwxr-xr-x. 2 root root 4.0K Apr 26 20:06 .
drwxr-xr-x. 9 root root 4.0K Apr 26 20:07 ..
-rwxr-xr-x. 1 root root 1.1K Jan 31  2011 trac.cgi
-rwxr-xr-x. 1 root root 1.1K Jan 31  2011 trac.fcgi


# yum update trac
Loaded plugins: changelog, downloadonly, fastestmirror
Loading mirror speeds from cached hostfile
 * base: archive.cs.uu.nl
 * epel: be.mirror.eurid.eu
 * extras: mirror.softaculous.com
 * updates: mirror.softaculous.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package trac.noarch 0:0.12.2-1.el6 will be updated
---> Package trac.noarch 0:0.12.3-3.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================
 Package                       Arch                            Version                                  Repository                     Size
============================================================================================================================================
Updating:
 trac                          noarch                          0.12.3-3.el6                             epel                          1.8 M

Transaction Summary
============================================================================================================================================
Upgrade       1 Package(s)

Total download size: 1.8 M
Is this ok [y/N]: y
Downloading Packages:
trac-0.12.3-3.el6.noarch.rpm                                                                                         | 1.8 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : trac-0.12.3-3.el6.noarch                                                                                                 1/2 
  Cleanup    : trac-0.12.2-1.el6.noarch                                                                                                 2/2 

Updated:
  trac.noarch 0:0.12.3-3.el6                                                                                                                

Complete!


# l
total 8.0K
drwxr-xr-x. 2 root root 4.0K Jul 20 14:41 .
drwxr-xr-x. 9 root root 4.0K Apr 26 20:07 ..
Comment 1 Ferry Huberts 2012-07-20 09:02:50 EDT
I saw the README but this breaks my installs all over the place.
On RHEL!
RHEL should never break, that's the point of RHEL: stable API
Comment 2 Ferry Huberts 2012-07-20 09:38:50 EDT
PS. it's because I'm using the shared setup with TRAC_ENV_PARENT_DIR.
Comment 4 Felix Schwarz 2014-11-08 06:58:38 EST
sorry for the late reply.

Ferry: You're right - this change wasn't in compliance with EPEL's packaging policy but it wasn't done by me and happened a long time ago.

The reason was probably that the ship files didn't work out of the box unless the admin did some (undocumented) configuration: See bug 720760 for more details.

As this happened a long time ago I think we should not revert this change because likely this would (again) surprise users. If you object please reopen this bug and I'll consider my decision :-)

Note You need to log in before you can comment on or make changes to this bug.