Bug 841905 - curl fails to build against newer version of libssh2-devel
curl fails to build against newer version of libssh2-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: curl (Show other bugs)
6.3
All Linux
medium Severity medium
: alpha
: ---
Assigned To: Kamil Dudka
Jiri Jaburek
: Patch
Depends On:
Blocks: 749873
  Show dependency treegraph
 
Reported: 2012-07-20 10:02 EDT by Kamil Dudka
Modified: 2013-02-21 05:09 EST (History)
2 users (show)

See Also:
Fixed In Version: curl-7.19.7-30.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:09:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Dudka 2012-07-20 10:02:40 EDT
Description of problem:
A suboptimally chosen identifier in curl sources clashes with an identifier introduced in a newer version of libssh2's public header file.


Version-Release number of selected component (if applicable):
curl-7.19.7-29.el6


Actual results:
ssh.c:122: error: conflicting types for 'libssh2_free'
/usr/include/libssh2.h:443: note: previous declaration of 'libssh2_free' was here


Upstream patch:
https://github.com/bagder/curl/commit/5997f54
Comment 11 errata-xmlrpc 2013-02-21 05:09:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0393.html

Note You need to log in before you can comment on or make changes to this bug.