Bug 841924 - hivex fails to parse W2K3 x64 hive, returning ENOTSUP because ri-record offset does not point to lf/lh
hivex fails to parse W2K3 x64 hive, returning ENOTSUP because ri-record offse...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hivex (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On: 717583
Blocks: 804821
  Show dependency treegraph
 
Reported: 2012-07-20 10:45 EDT by Richard W.M. Jones
Modified: 2013-02-21 05:28 EST (History)
9 users (show)

See Also:
Fixed In Version: hivex-1.3.3-4.2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 717583
Environment:
Last Closed: 2013-02-21 05:28:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-20 10:45:31 EDT
+++ This bug was initially created as a clone of Bug #717583 +++

Description of problem:

https://www.redhat.com/archives/libguestfs/2011-June/msg00135.html

I think this is a case of ri-record pointing to a second level
ri-record which we've never seen before, but I have not had
time to look into this in detail.

Version-Release number of selected component (if applicable):

hivex 1.2.7.

Steps to Reproduce:

See the software hive attached to the email message above.

--- Additional comment from rjones@redhat.com on 2012-03-08 13:10:47 EST ---

There is a potential fix, which needs review, posted upstream:
https://www.redhat.com/archives/libguestfs/2012-March/msg00035.html
Comment 2 Karl Stevens 2012-07-26 05:29:26 EDT
Adding Peter Parsons to cc who's the platform SA working with 888, the customer we discovered this on.
Comment 3 Richard W.M. Jones 2012-10-11 07:47:53 EDT
Fix committed upstream:
https://github.com/libguestfs/hivex/commit/c29d2625c2286b026c4e36a8b5469991c41b4299

Note to QA, try the following:

(1) Download and uncompress the test hive here:
    https://www.redhat.com/archives/libguestfs/2011-June/msg00135.html

(2) Open it with hivexsh:

$ hivexsh Software 

(3) Try to display the Software\Classes directory:

Software\> cd Classes
Software\Classes> ls
ls: Operation not supported

(4) Now try again with the updated hivexsh program, and instead
of the "Operation not supported" error you should see a long list
of classes.
Comment 5 Mohua Li 2012-11-29 01:43:56 EST
got the Software attachment from maillist, with hivex-1.3.3-4.2.el6.x86_64

[lmh@station2 tmp]$ file Software 
Software: MS Windows registry file, NT/2000 or above

$hivexsh Software 


Software\> cd Classes
Software\Classes> ls

.............
............
WMP.RipCD
WMP.WMDBFile
WMPlayer.OCX
WMPlayer.OCX.7
WMPTheme.WMPSkinMngr
WMPTheme.WMPSkinMngr.1
WMSFile
WMVFile
WMZFile
Wordpad.Document.1
Wow6432Node
WPDSp.WPDServiceProvider
WPDSp.WPDServiceProvider.1
WPLFile
wrifile
WScript.Network
WScript.Network.1
WScript.Shell
WScript.Shell.1
Wsecedit.Extension
Wsecedit.Extension.1
Wsecedit.LS
Wsecedit.LS.1
Wsecedit.LSAbout.1
Wsecedit.RSOP
Wsecedit.RSOP.1
Wsecedit.RSOPAbout.1
Wsecedit.SAV
Wsecedit.SAV.1
Wsecedit.SCE
Wsecedit.SCE.1
Wsecedit.SCEAbout.1
Wsecedit.SCMAbout.1
Wsecedit.SSAbout.1
WSFFile
WSHController
WSHFile
WSHRemote
WVXFile
x-internet-signup
xbmfile
XML
.................
.......................
Comment 7 errata-xmlrpc 2013-02-21 05:28:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0433.html

Note You need to log in before you can comment on or make changes to this bug.