Bug 841925 - doesn't build against CUPS 1.6
doesn't build against CUPS 1.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Net-CUPS (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On: 832130
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 10:47 EDT by Jiri Popelka
Modified: 2012-08-09 04:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-Net-CUPS-0.61-12.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:45:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to build against CUPS 1.6 (5.16 KB, patch)
2012-07-20 10:47 EDT, Jiri Popelka
no flags Details | Diff

  None (edit)
Description Jiri Popelka 2012-07-20 10:47:00 EDT
Created attachment 599408 [details]
patch to build against CUPS 1.6

Hi,

CUPS 1.6 has been planned to be out this summer.
There's however one feature [1] that prevents
perl-Net-CUPS from building against it.

CUPS 1.6 makes various structures private and
introduces several ippGet and ippSet functions
for all of the fields in these structures.

I'm attaching a patch that fixes it for me (tested with CUPS-1.6rc1).
With this patch we use these accessors for IPP API.
We also define our own accessors when CUPS < 1.6.

Upstream seems to be quite dead at first glance,
but I'll be glad if you could try to push the patch there.

You will also need to add
BuildRequire cups-filters-devel
to the spec file once cups-1.6 and cups-filters (bug #832130)
land in rawhide.

[1] http://www.cups.org/str.php?L3928
Comment 1 Petr Šabata 2012-07-26 08:07:56 EDT
Thanks, I like the patch.
I've included it in our current package since it doesn't break anything.  I'll add the dependency once the new release lands in Rawhide.

I pushed it upstream as RT#78583.
https://rt.cpan.org/Public/Bug/Display.html?id=78583

Note You need to log in before you can comment on or make changes to this bug.