Bug 841941 - amarok plays the same file twice
amarok plays the same file twice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: phonon-backend-gstreamer (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 11:26 EDT by Jan Vcelak
Modified: 2013-03-03 20:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 14:30:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 303580 None None None 2012-07-24 14:51:30 EDT

  None (edit)
Description Jan Vcelak 2012-07-20 11:26:13 EDT
Description of problem:

When the track finishes playing in Amarok, the next track is marked as active in the playlist but the previous file is played again. If I double-click on the track the correct file is played.

Looks like a regression, the issue disappeared after downgrading to phonon-backend-gstreamer-4.6.0-1.fc17.x86_64

Version-Release number of selected component (if applicable):

phonon-backend-gstreamer-4.6.1-1.fc17.x86_64
amarok-2.5.0-9.fc17.x86_64


How reproducible:
100%


Steps to Reproduce:
1. create playlist with 3 tracks, disable any random/repeat stuff
2. start the first track
3. move the "progress bar" approximately 10 seconds before the end of the track and wait
  
Actual results:
The next track is marked as active but the first track is played again.


Expected results:
The next track is marked as active and that track is played.


Additional info:
Comment 1 Rex Dieter 2012-07-24 14:51:29 EDT
confirmed, pulling update for now.
Comment 2 Fedora Update System 2012-07-26 10:19:56 EDT
phonon-backend-gstreamer-4.6.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/phonon-backend-gstreamer-4.6.1-3.fc17
Comment 3 Fedora Update System 2012-07-26 10:27:09 EDT
phonon-backend-gstreamer-4.6.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/phonon-backend-gstreamer-4.6.1-3.fc16
Comment 4 Fedora Update System 2012-07-26 18:22:38 EDT
Package phonon-backend-gstreamer-4.6.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing phonon-backend-gstreamer-4.6.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11124/phonon-backend-gstreamer-4.6.1-3.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-08-01 14:30:26 EDT
phonon-backend-gstreamer-4.6.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-08-10 18:32:42 EDT
phonon-backend-gstreamer-4.6.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.