Bug 841945 - [abrt] evolution-data-server-3.4.3-1.fc17: io_error: Process /usr/libexec/evolution-addressbook-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.4.3-1.fc17: io_error: Process /usr/libexec/evo...
Status: CLOSED DUPLICATE of bug 750036
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:eb68fea3dfa4e44f2a8db337133...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 11:32 EDT by Reinout van Schouwen
Modified: 2012-07-24 11:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 11:14:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (19.54 KB, text/plain)
2012-07-20 11:32 EDT, Reinout van Schouwen
no flags Details
File: maps (96.72 KB, text/plain)
2012-07-20 11:32 EDT, Reinout van Schouwen
no flags Details
File: build_ids (8.73 KB, text/plain)
2012-07-20 11:32 EDT, Reinout van Schouwen
no flags Details
File: backtrace (43.00 KB, text/plain)
2012-07-20 11:32 EDT, Reinout van Schouwen
no flags Details

  None (edit)
Description Reinout van Schouwen 2012-07-20 11:32:09 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-addressbook-factory
core_backtrace: 
crash_function: io_error
executable:     /usr/libexec/evolution-addressbook-factory
kernel:         3.4.4-5.fc17.x86_64
pid:            2345
pwd:            /
time:           vr 20 jul 2012 14:03:02 CEST
uid:            500
username:       reinout
xsession_errors: 

backtrace:      Text file, 44033 bytes
build_ids:      Text file, 8938 bytes
dso_list:       Text file, 20014 bytes
maps:           Text file, 99038 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/reinout/7

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-aiehRlRvuO,guid=e0dda3c991bec3aaf677fd770000251d
:XDG_SESSION_COOKIE=2fa431ccfb3b706e4976ae8c00000013-1342733546.609090-1048856996
:XDG_RUNTIME_DIR=/run/user/reinout
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/run/user/reinout/keyring-COCAM5/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1612,unix/unix:/tmp/.ICE-unix/1612
:WINDOWPATH=2
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=2
:USERNAME=reinout
:XDG_SESSION_ID=7
:GPG_AGENT_INFO=/run/user/reinout/keyring-COCAM5/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-aiehRlRvuO,guid=e0dda3c991bec3aaf677fd770000251d
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-reinout-l93CFH/database
:USER=reinout
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1608
:SHLVL=1
:GDM_LANG=nl_NL.utf8
:PWD=/home/reinout
:GNOME_KEYRING_CONTROL=/run/user/reinout/keyring-COCAM5
:LANG=nl_NL.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=reinout
:HOME=/home/reinout

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63130                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63130                63130                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:/dev/null
:pos:	0
:flags:	0100002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[31757]
:pos:	0
:flags:	04002
:7:socket:[31758]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:/home/reinout/.local/share/evolution/addressbook/system/addressbook.db
:pos:	0
:flags:	02100002
:11:/home/reinout/.local/share/evolution/addressbook/system/contacts.db
:pos:	40
:flags:	02100002
:12:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:13:/home/reinout/.cache/evolution/addressbook/mapigal___xxxxod.intern_;Global Address List/contacts.db
:pos:	40
:flags:	02100002
:14:/home/reinout/.cache/evolution/addressbook/mapi___xxxxod.intern_;Contacts/contacts.db
:pos:	40
:flags:	02100002
:15:socket:[675852]
:pos:	0
:flags:	02004002
Comment 1 Reinout van Schouwen 2012-07-20 11:32:12 EDT
Created attachment 599418 [details]
File: dso_list
Comment 2 Reinout van Schouwen 2012-07-20 11:32:16 EDT
Created attachment 599419 [details]
File: maps
Comment 3 Reinout van Schouwen 2012-07-20 11:32:19 EDT
Created attachment 599420 [details]
File: build_ids
Comment 4 Reinout van Schouwen 2012-07-20 11:32:21 EDT
Created attachment 599421 [details]
File: backtrace
Comment 5 Milan Crha 2012-07-23 14:03:24 EDT
Thanks for a bug report. This seems like a crash under libgdata.

Philip, does it sound familiar for you, please? I this I saw something similar, but I cannot find it now.
Comment 6 Philip Withnall 2012-07-23 19:49:41 EDT
(In reply to comment #5)
> Philip, does it sound familiar for you, please? I this I saw something
> similar, but I cannot find it now.

Fairly sure it’s: https://bugzilla.gnome.org/show_bug.cgi?id=663084, which was fixed here: http://git.gnome.org/browse/libsoup/commit/?id=d0d534568c97271e03a0e9f9c16a0966fb50b97a.
Comment 7 Milan Crha 2012-07-24 11:14:40 EDT
Thanks Philip. I'm marking this as a duplicate of a corresponding downstream bug report, and from what I see then Dan built libsoup-2.38.1-2.fc17 on 19th, and made it available as update [1] for the other bug.

Reinout, it'll be good if you could give it a try and comment on the update whether it helped you.

[]1 https://admin.fedoraproject.org/updates/FEDORA-2012-10896/libsoup-2.38.1-2.fc17

*** This bug has been marked as a duplicate of bug 750036 ***

Note You need to log in before you can comment on or make changes to this bug.