Bug 84196 - Erratic mouse when switching back to linux using KVM switch
Erratic mouse when switching back to linux using KVM switch
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-13 06:25 EST by Richard Tresidder
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 06:48:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Tresidder 2003-02-13 06:25:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0 (CK-APC)

Description of problem:
This Bug is known about however from what I'm reading on previous reports the
solution put forward is to buy another switch!
This is a hardware problem admitedly but every other operating system seems to
of found a work around for it. 
AND NOW
This bug has been fixed in XFree86 latest release as of a month ago but still
nothing has been done to provided an update for XFree86 for Redhat
I would (and I'm sure many others) would really like to  have an update for this.
I don't really want to have to download the sources myself and figure out how to
install it..
At the moment the problem affects and IMPS/2 mice, not standard PS/2 mice
However I really like the little wheel and third button :)
The only way around this problem at the moment is to do a
CTRL+ALT+F1 then CTRL+ALT+F7, this resets the mouse and gets things back in
sync, and is a pain when switching back and forth all the time.

Sorry this was a bit long winded
Thanks
Richard Tresidder

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Switch to another computer
2. switch back to linux computer
3. crazy mouse
    

Actual Results:  Mouse mayhem

Expected Results:  Happy controlable mouse

Additional info:
Comment 1 Mike A. Harris 2003-02-13 06:48:56 EST
KVM switches are unsupported - regardless of where the problem exists, be
it in the KVM switch, XFree86, the mouse/keyboard/monitor/videocard or
wherever.  If a KVM switch works, that is great, but if it does not, then
the user using that KVM switch has found out the hard way why we do not
support KVM switches.

Also, Red Hat does not release updates of software the size of XFree86 for
a single bug or single issue such as this, even if it is with supported
hardware.  In general, XFree86 is updated only when there are security
issues that need to be fixed.  Occasionally we release updates as well
for software bugs, but not for one single bug.  And this one isn't a bug.

The fix you are refering to, is a software workaround for a KVM glitch,
one that is not supported.  That fix will not be backported to prior
versions of Red Hat Linux.  Red Hat developmental rawhide and our phoebe
beta contain the latest XFree86 code, and you can try our beta or wait
until our final release of our next OS if you would like to try the
XFree86 version that alledgedly works around this KVM switch hardware bug.

The alternative is to purchase a better KVM switch that does not have this
hardware problem - although even proper working KVM's are still unsupported.
If you require details as to why KVM switches are supported, you can query
bugzilla with the keyword "KVM" against the XFree86 component if you like.

I'm closing this issue as NOTABUG for 7.3, but it is also effectively
closed RAWHIDE since the fix you mention is in CVS X, which is in RAWHIDE.



Note You need to log in before you can comment on or make changes to this bug.