Bug 841961 - rhsm-migrate-classic-to-rhsm --servicelevel should be case insensitive
rhsm-migrate-classic-to-rhsm --servicelevel should be case insensitive
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-20 13:02 EDT by John Sefler
Modified: 2013-01-07 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Bryan Kearney 2012-08-17 14:07:44 EDT
fixed in master at 2d097182f975b3d050765e52f3e3788be77f6065.
Comment 2 RHEL Product and Program Management 2012-08-29 17:07:29 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 John Sefler 2012-09-07 17:10:03 EDT
Verifying Version...
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.0.17-1.el5



[root@rhsm-accept-rhel5 ~]# rhnreg_ks --serverUrl=https://xmlrpc.rhn.code.stage.redhat.com/XMLRPC --username=qa@redhat.com --password=**** --force --norhnsd --nohardware --nopackages --novirtinfo

[root@rhsm-accept-rhel5 ~]# rhn-migrate-classic-to-rhsm --servicelevel="nOnE"
Red Hat account: qa@redhat.com
Password: 

Retrieving existing RHN Classic subscription information ...
+----------------------------------+
System is currently subscribed to these RHN Classic Channels:
+----------------------------------+
rhel-x86_64-server-5

+--------------------------------------------------+ 
Installing product certificates for these RHN Classic channels:
+--------------------------------------------------+
rhel-x86_64-server-5

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from RHN Classic ...
System successfully unregistered from RHN Classic.

Attempting to register system to Red Hat Subscription Management ...
The system has been registered with id: 1c1f7d06-a1bb-430d-8c63-acae614afad4 
System 'rhsm-accept-rhel5.usersys.redhat.com' successfully registered to Red Hat Subscription Management.

Attempting to auto-subscribe to appropriate subscriptions ...
Service level set to: nOnE
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed


Please visit https://access.redhat.com/management/consumers/1c1f7d06-a1bb-430d-8c63-acae614afad4 to view the details, and to make changes if necessary.

[root@rhsm-accept-rhel5 ~]# subscription-manager service-level --list
+-------------------------------------------+
               Available Service Levels
+-------------------------------------------+
SELF-SUPPORT
PREMIUM
STANDARD
NONE

[root@rhsm-accept-rhel5 ~]# subscription-manager service-level --show
Current service level: nOnE

[root@rhsm-accept-rhel5 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Red Hat Employee Subscription
Provides:             	Red Hat Enterprise Linux Server
                      	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
                      	Red Hat Enterprise Linux Scalable File System (for RHEL Server)
                      	Red Hat Beta
                      	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
                      	Red Hat Enterprise Linux High Availability (for RHEL Server)
                      	Red Hat Enterprise Linux Workstation
SKU:                  	SYS0395
Contract:             	2596950
Account:              	477931
Serial Number:        	1550672064496732006
Active:               	True
Quantity Used:        	1
Service Level:        	None
Service Type:         	None
Starts:               	10/05/2011
Ends:                 	01/01/2022

[root@rhsm-accept-rhel5 ~]# 


^^ VERIFIED: I specified that I wanted to migrate with --servicelevel="nOnE" and despite the case, I was successfully autosubscribed to a subscription that provided a service level of "None".
Comment 6 errata-xmlrpc 2013-01-07 22:57:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.