Bug 841978 - NetworkManager broken VPN
NetworkManager broken VPN
Status: CLOSED DUPLICATE of bug 817851
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 14:00 EDT by Nathaniel McCallum
Modified: 2012-07-26 05:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 05:54:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathaniel McCallum 2012-07-20 14:00:08 EDT
A recent yum update in rawhide broke my VPN access. Here is the error from the log:

NetworkManager[1034]: <error> [1342806413.569960] [nm-vpn-connection.c:1405] get_secrets_cb(): Failed to request VPN secrets #3: (6) No agents were available for this request.
Comment 1 Dan Williams 2012-07-20 16:23:12 EDT
Are you running GNOME Shell?  If so, I believe this is due to GNOME Shell and dbus-glib issues.  Make sure you're running dbus-glib 0.100 or later and latest gnome-shell packages.  If not using the Shell, then it's something else.

This message means that the thing that provides secrets to NM is no longer running.  That thing is usually GNOME Shell, nm-applet, or KDE network management.  If none of those things are running, then nothing is available to ask you for your VPN password.
Comment 2 Nathaniel McCallum 2012-07-20 19:56:36 EDT
dbus-glib-0.100-1.fc18.x86_64
gnome-shell-3.5.4-3.fc18.x86_64
Comment 3 Nathaniel McCallum 2012-07-20 19:57:12 EDT
network-manager-applet-0.9.5.95-2.git20120713.fc18.x86_64
Comment 4 Jirka Klimes 2012-07-23 03:58:56 EDT
Nathaniel, do you see any crash of NM, gnome-shell, nm-applet?
Would you attach /var/log/messages and ~/.xsession-errors?
Comment 5 Nathaniel McCallum 2012-07-23 10:59:28 EDT
This appears to have gone away. I'm wondering if I was actually running a mismatch of versions or something. Anyway, fixed for now.
Comment 6 Jirka Klimes 2012-07-26 05:54:08 EDT
It's been fixed by updating dbus-glib.

*** This bug has been marked as a duplicate of bug 817851 ***

Note You need to log in before you can comment on or make changes to this bug.