Bug 841989 - "Action on title bar double-click: Toggle Shade" is ignored
"Action on title bar double-click: Toggle Shade" is ignored
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
https://github.com/linuxmint/Cinnamon...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 15:13 EDT by Jeff Layton
Modified: 2014-06-18 03:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 18:23:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2012-07-20 15:13:20 EDT
I have cinnamon set up with "Action on Title Bar double-click" set to "Toggle Shade". When I double click on the title bar, it maximizes the window instead. I get pretty much the same results when I set it to "Minimize" so I believe it's just universally ignored.

I'm using:

cinnamon-1.4.1-0.4.git7959517.fc17.x86_64
muffin-1.0.4-0.4.gitfcea2f1.fc17.x86_64

...and this seems to be a regression from cinnamon-1.4.0-5.UP1.fc17.x86_64.
Comment 1 leigh scott 2012-07-20 15:23:42 EDT
Thank you for reporting it, I have forwarded it upstream

https://github.com/linuxmint/Cinnamon/issues/944
Comment 2 leigh scott 2012-07-20 20:37:21 EDT
I have made a pull request to fix this issue


https://github.com/linuxmint/Cinnamon/pull/945
Comment 3 Fedora Update System 2012-07-21 05:06:44 EDT
cinnamon-1.4.1-0.9.git7959517.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cinnamon-1.4.1-0.9.git7959517.fc17
Comment 4 Jeff Layton 2012-07-21 06:13:58 EDT
Hmm...negative. The setting still seems to be ignored even with that version.

cinnamon-1.4.1-0.8.git7959517.fc17.x86_64
muffin-1.0.4-0.4.gitfcea2f1.fc17.x86_64
Comment 5 Jeff Layton 2012-07-21 06:18:54 EDT
Oops, sorry...

.9.git does fix it (was looking for the git commit to change).
Comment 6 Fedora Update System 2012-07-21 18:53:14 EDT
Package cinnamon-1.4.1-0.9.git7959517.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-1.4.1-0.9.git7959517.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10960/cinnamon-1.4.1-0.9.git7959517.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-07-26 09:13:46 EDT
muffin-1.0.5-1.fc17, cinnamon-1.5.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/muffin-1.0.5-1.fc17,cinnamon-1.5.1-1.fc17
Comment 8 Fedora Update System 2012-07-27 14:43:05 EDT
cinnamon-1.5.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cinnamon-1.5.2-1.fc17
Comment 9 Fedora Update System 2012-07-30 10:02:25 EDT
cinnamon-1.5.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cinnamon-1.5.2-2.fc17
Comment 10 Fedora Update System 2012-07-30 18:23:35 EDT
muffin-1.0.5-1.fc17, cinnamon-1.5.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-07-30 18:26:02 EDT
cinnamon-1.5.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.