Bug 84199 - driver and daemon fail to start
driver and daemon fail to start
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: nut (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-13 08:14 EST by Markku Kolkka
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 10:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2003-02-13 08:14:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When trying to start ups service (after configuring it) both the hidups driver
and upsd fail with errror message:
"getpwnam() failed: user 57 does not exist"

Version-Release number of selected component (if applicable):
nut-1.2.0-5

How reproducible:
Always

Steps to Reproduce:
1.service ups start
2.
3.
    

Actual Results:  # service ups start
Starting hidups: getpwnam() failed: user 57 does not exist
                                                           [FAILED]
Starting upsd: Network UPS Tools upsd 1.2.0
/var/lib/ups is world readable
Warning: Data for UPS [apc] is stale - check driver
getpwnam() failed: user 57 does not exist
                                                           [FAILED]
Starting UPS monitor (master):                             [  OK  ]


Expected Results:  Three green [OK]s

Additional info:
User "nut" with UID=57 exists in /etc/passwd
Comment 1 Ngo Than 2003-02-13 10:35:45 EST
It's fixed in 1.2.0-6. Could you please test it again. Thanks

Note You need to log in before you can comment on or make changes to this bug.